Lights out not detecting or initiating backups after Active Backup for Business update

Problems or questions about Lights-Out on Synology DSM are answered here
Antworten
BeverlyB
Foren-Einsteiger
Beiträge: 32
Registriert: 24. Nov 2017, 14:15

Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von BeverlyB » 9. Nov 2019, 17:30

Active Backup for Business was updated on my NAS on Nov 7 and Lights Out is no longer detecting when backups are running and can no longer initiate a backup.

I can run the backup task manually and it runs at the time scheduled via the Active Backup task.
I have not tried the most recent Lights Out beta (The one with QNAP support in it). I know it has some improvements for Synology as well.
Do you think it will work with this version of Active Backup or is this a new issue?

Benutzeravatar
Martin
Moderator
Beiträge: 9464
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von Martin » 11. Nov 2019, 08:50

The latest update of ABfB includes some incompatible changes which makes it necessary to update Lights-Out. I have implemented most changes but have not (yet?) found a way to start a backup from within Lights-Out. You can download a test build here: https://www.green-it-software.com/downl ... 7_Beta.spk
Install this update manually on the NAS. It will update the existing version automatically.

Regards
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

BeverlyB
Foren-Einsteiger
Beiträge: 32
Registriert: 24. Nov 2017, 14:15

Re: Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von BeverlyB » 12. Nov 2019, 15:38

It seems to be behaving a little better. There are still a couple of issues, though.

I have a calendar task to turn on my laptop a few minutes before the ABfB task is scheduled to run and also to wake the server (thought the server is most likely already awake because I have another calendar task setup to wake the server in time for the retention task to run).
I set an end time for my laptop's task and told it to turn off my laptop when the backup is done or if it's idle for 15 minutes.
It didn't seem to detect when the backup was done (even though the client on the laptop was able to detect it) but it did turn the laptop off 15 minutes later (when the laptop was idle for 15 minutes).

In the backup tab of the lights-out settings, I see Active Backup in the list, but it is greyed out and unchecked. I'm not sure if this new version of ABfB will allow you to do anything about that or not, but I imagine if the client knows that a backup is running, there should be some way to enable this.

Benutzeravatar
Martin
Moderator
Beiträge: 9464
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von Martin » 20. Nov 2019, 17:42

Sorry for my late reply.

Have you installed the test build? Because that should detect ABfB on the NAS. As a result, ABfB should be grayed out but checked. If that does not work for you, please send me your logs. Open Lights-Out Console. Click on settings. Go to the server tab. Click on download log files. Either attach the logs here or send me a private mail.

Regards
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

BeverlyB
Foren-Einsteiger
Beiträge: 32
Registriert: 24. Nov 2017, 14:15

Re: Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von BeverlyB » 22. Nov 2019, 03:12

Yes, I installed the test build. ABfB is greyed out and unchecked.
I sent the logs in a private message.

I just noticed that my PC did not wake up for a backup since Nov 18.
I just checked the wake timers and it is scheduled to wake up at the configured backup time tonight.

BeverlyB
Foren-Einsteiger
Beiträge: 32
Registriert: 24. Nov 2017, 14:15

Re: Lights out not detecting or initiating backups after Active Backup for Business update

Beitrag von BeverlyB » 22. Nov 2019, 18:03

My PC did wake up for the backup last night. But the waketimer did not get set for tonight.

EDIT: I just turned on the NAS and checked the wake timers again. They are now set for tonight.
When does lightsout set the waketimers for the next day?

I have a calendar action set to wake my PC at 1:00AM. and to perform the "standard action" at the end time which is set for 2:00am.
I checked "execute after backup" and "execute if idle for 15 minutes"

I looked at the event viewer on my PC and it looks like it performed the "standard action" (it says sleep but I set it to hibernate) 5 minutes after the backup completed at 1:07:30. (backup was only 2 minutes - not many changes on my system since I did a manual backup earlier in the day)

Antworten