Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Problems or questions about Lights-Out on QNAP QTS are answered here
Antworten
s.momonga
Foren-Einsteiger
Beiträge: 2
Registriert: 17. Sep 2022, 01:42

Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von s.momonga » 17. Sep 2022, 01:50

hello.

Mono Framework support has been removed from QTS 5.0.1.2145 build 20220903.
Therefore, Lights-Out does not work.

https://www.qnap.com/en/release-notes/q ... as_product
・Removed support for the following apps or tools: Mono, Perl, and AlarmClock.
 We recommend running these apps or tools using Container Station if needed.

Is there any workaround?

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 18. Sep 2022, 12:59

s.momonga hat geschrieben:
17. Sep 2022, 01:50
hello.

Mono Framework support has been removed from QTS 5.0.1.2145 build 20220903.
Therefore, Lights-Out does not work.

https://www.qnap.com/en/release-notes/q ... as_product
・Removed support for the following apps or tools: Mono, Perl, and AlarmClock.
 We recommend running these apps or tools using Container Station if needed.

Is there any workaround?
Hi, I can confirm the same situation!

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 18. Sep 2022, 21:28

mikel99 hat geschrieben:
18. Sep 2022, 12:59
s.momonga hat geschrieben:
17. Sep 2022, 01:50
hello.

Mono Framework support has been removed from QTS 5.0.1.2145 build 20220903.
Therefore, Lights-Out does not work.

https://www.qnap.com/en/release-notes/q ... as_product
・Removed support for the following apps or tools: Mono, Perl, and AlarmClock.
 We recommend running these apps or tools using Container Station if needed.

Is there any workaround?
Hi, I can confirm the same situation!
QMono from qnapclub.eu seems to install. BUT, as it is a 6.X version, lights out does not start with it.

QNAP refuses to install previous versions of QMono even if you have the relevant .qpkg

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 19. Sep 2022, 10:38

mikel99 hat geschrieben:
18. Sep 2022, 21:28
mikel99 hat geschrieben:
18. Sep 2022, 12:59
s.momonga hat geschrieben:
17. Sep 2022, 01:50
hello.

Mono Framework support has been removed from QTS 5.0.1.2145 build 20220903.
Therefore, Lights-Out does not work.

https://www.qnap.com/en/release-notes/q ... as_product
・Removed support for the following apps or tools: Mono, Perl, and AlarmClock.
 We recommend running these apps or tools using Container Station if needed.

Is there any workaround?
Hi, I can confirm the same situation!
QMono from qnapclub.eu seems to install. BUT, as it is a 6.X version, lights out does not start with it.

QNAP refuses to install previous versions of QMono even if you have the relevant .qpkg

5.8 version can be installed within a Docker Container.... but here I don´t know what ports should be exposed or how does LightsOut detect that Mono is available... so far with Mono started as a Container Image, I still get this when I try to start LightstOut:
"Qmono is required for Lights-Out but is currently disabled"

Benutzeravatar
Martin
Moderator
Beiträge: 9859
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von Martin » 19. Sep 2022, 10:52

Hi all,

It does not help to use docker! Lights-Out requires a working Mono installation outside of docker.

Lights-Out works with QMono 6.8 only, Qmono 6.12 does not work unfortunately.
However, QMono 6.8. is configured with max version 5.0.0, so QTS 5.0.1 blocks the installation.

Currently I'm checking possible workarounds. Will come back as soon as I can tell more.

Regards
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 19. Sep 2022, 11:48

Martin hat geschrieben:
19. Sep 2022, 10:52
Hi all,

It does not help to use docker! Lights-Out requires a working Mono installation outside of docker.

Lights-Out works with QMono 6.8 only, Qmono 6.12 does not work unfortunately.
However, QMono 6.8. is configured with max version 5.0.0, so QTS 5.0.1 blocks the installation.

Currently I'm checking possible workarounds. Will come back as soon as I can tell more.

Regards
Martin
Thanks for the prompt response.
Let us know if you need any help or alpha-testers!

Benutzeravatar
Martin
Moderator
Beiträge: 9859
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von Martin » 19. Sep 2022, 16:28

Please install QMono 6.12 and then update to this beta version of Lights-Out
https://www.green-it-software.com/downl ... .4860.qpkg

Feedback welcome!
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 19. Sep 2022, 18:27

Martin hat geschrieben:
19. Sep 2022, 16:28
Please install QMono 6.12 and then update to this beta version of Lights-Out
https://www.green-it-software.com/downl ... .4860.qpkg

Feedback welcome!
Martin
Flawless install. Working as expected.
It has survived a couple of reboots. Calendar events and other configuration seems ok.
I will post again in a couple of days once it has had time to do it's magic overnight :D

s.momonga
Foren-Einsteiger
Beiträge: 2
Registriert: 17. Sep 2022, 01:42

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von s.momonga » 20. Sep 2022, 08:29

I installed QMONO6.12.0.200 and Lights-Out 3.7.1.4860 in my environment.

I've also tried rebooting and it's working fine.
Also, the calendar settings are fine.
I'll see how it goes for a while.

Thank you for your prompt response.

mikel99
Foren-Einsteiger
Beiträge: 11
Registriert: 16. Sep 2019, 13:50

Re: Lights-Out 3 for QNAP QTS does not work with QTS 5.0.1.2145 build 20220903.

Beitrag von mikel99 » 22. Sep 2022, 13:00

mikel99 hat geschrieben:
19. Sep 2022, 18:27
Martin hat geschrieben:
19. Sep 2022, 16:28
Please install QMono 6.12 and then update to this beta version of Lights-Out
https://www.green-it-software.com/downl ... .4860.qpkg

Feedback welcome!
Martin
Flawless install. Working as expected.
It has survived a couple of reboots. Calendar events and other configuration seems ok.
I will post again in a couple of days once it has had time to do it's magic overnight :D
So far, so good! No problems at all.

Thanks!

Antworten