Lights-Out on DSM 7

Problems or questions about Lights-Out on Synology DSM are answered here
Antworten
Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Lights-Out on DSM 7

Beitrag von Martin » 3. Aug 2021, 17:59

Unfortunately, things do not look good with DSM 7.

Synology does not allow packages running with root privileges with DSM 7.
During the beta there was a workaround (bug) https://community.synology.com/enu/forum/20/post/140589
but this has been blocked or fixed in the meantime.

Without root privileges Lights-Out can not do anything, neither monitor network traffic nor shutdown the server.

Whether the users are willing to edit files via SSH to give Lights-Out root rights is questionable.

I will prepare a test package to see what else needs to be changed, but simply installing it won't work.

The outcry in the community is so far also rather restrained and will certainly not move Synology to provide an option.

Greetings
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out on DSM 7

Beitrag von Martin » 8. Aug 2021, 19:42

I'll probably release a beta on Wednesday, and in it I'll describe the manual steps on how to get root privileges for Lights-Out again.

Regards
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out on DSM 7

Beitrag von Martin » 11. Aug 2021, 21:51

Here's the promised beta:
https://www.green-it-software.com/10289 ... available/

Have fun!
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Etupes25
Foren-Einsteiger
Beiträge: 5
Registriert: 21. Sep 2021, 03:54

Re: Lights-Out on DSM 7

Beitrag von Etupes25 » 21. Sep 2021, 04:00

Hey,

I have uploaded the package to DSM 7.0, but I had to uninstall it after I realized Mono was not installed. I have now installed Mono, but I cannot reload the beta package. It gets stuck at "processing changes" right after I select the package for upload. Any idea how I could clean up the situation?

Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out on DSM 7

Beitrag von Martin » 21. Sep 2021, 08:22

Have you run make-root via ssh?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Etupes25
Foren-Einsteiger
Beiträge: 5
Registriert: 21. Sep 2021, 03:54

Re: Lights-Out on DSM 7

Beitrag von Etupes25 » 21. Sep 2021, 23:38

I couldn't get there, because I cannot install Lights-Out at all. I have mono installed. When I try to do a manual install of the lights-out beta spk package, it doesn't even get to the warning about not being an official package. I just see "processing changes".
There may be some issue with left-overs from the previous successful installation/uninstallation and I guess there must be a way to use SSH to clean this up and make sure the next install is a clean install, but I am a noob with Linux admin and I am just stuck, not being able to install the beta package a second time.

Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out on DSM 7

Beitrag von Martin » 22. Sep 2021, 09:17

Can you please add a screen shot of this message?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Etupes25
Foren-Einsteiger
Beiträge: 5
Registriert: 21. Sep 2021, 03:54

Re: Lights-Out on DSM 7

Beitrag von Etupes25 » 23. Sep 2021, 00:05

Hey,

So, I tried again today and it worked. I don't know what changed. I suspect my Firewalla home network security device was blocking some site,... and then stopped blocking it/them? Not sure.
At any rate I was able to reinstall the package and I will proceed with giving it the right privileges.

Etupes25
Foren-Einsteiger
Beiträge: 5
Registriert: 21. Sep 2021, 03:54

Re: Lights-Out on DSM 7

Beitrag von Etupes25 » 23. Sep 2021, 01:42

Here is what happened. I was successful at installing the package. I then tried to connect with the console from a Windows PC. That didn't work.
LO Console SSL issue.PNG
LO Console SSL issue.PNG (55.11 KiB) 65 mal betrachtet
I looked around and found some posts about recreating the certificate. I deleted the certificate and rebooted the NAS. The certificate is back.
LO certif.PNG
LO certif.PNG (11.75 KiB) 65 mal betrachtet
The reverse proxy looks correct.
LO Reverse Proxy.PNG
LO Reverse Proxy.PNG (11.52 KiB) 65 mal betrachtet
However I cannot connect with the console.

NB> I tried to reinstall the package and got the same problem as before, FYI
Lights-Out3 on DSM7.0 Install 2of2.PNG
Lights-Out3 on DSM7.0 Install 2of2.PNG (34.97 KiB) 68 mal betrachtet
.

Benutzeravatar
Martin
Moderator
Beiträge: 9648
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Lights-Out on DSM 7

Beitrag von Martin » 23. Sep 2021, 08:50

You have two issues. Let's try to answer each.

1. Successful installation, but failed login

That happens because you do not use the name of the NAs. The IP-Address does not work because the certificate only has the name. Please enter zpcloud without any port.


2. Unsuccessful reinstallation

Have you tried a NAS reboot?

"Processing. Please wait..." happens while the package gets uploaded to the NAS.
How long have you waited in that screen?

Which version have you tried to install? Build 4770 or 4775?
Which NAs are you using (model)?

Regards
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Etupes25
Foren-Einsteiger
Beiträge: 5
Registriert: 21. Sep 2021, 03:54

Re: Lights-Out on DSM 7

Beitrag von Etupes25 » 23. Sep 2021, 16:58

Hello Martin,

1) I tried the IP address because using the name was generating unspecified errorrs, see below
LO Console SSL issue 2.PNG
LO Console SSL issue 2.PNG (36.9 KiB) 27 mal betrachtet
I don't know if this is relevant by "ZPCloud" is also the name for quickconnect access

2) Yes, I have tried a NAS reboot. This is the only way I can get out of the Package Center Processing Changes situation. I have let that situation go on for about an hour, so I am showing impatience either :-)

I am using 3.7.0.4770

My NAS is a 718+ model

Thank you very much for your quick follow up!

Antworten