OpenVPN einrichten

Diskussionen rund um Windows Server 2016 Essentials
Antworten
Coolio510
Foren-Mitglied
Beiträge: 51
Registriert: 11. Jan 2008, 17:22

OpenVPN einrichten

Beitrag von Coolio510 » 29. Sep 2019, 09:58

Hi,

würde gern VPN mit dem 2016er Essentials nutzen.
Leider finde ich nirgends Tips oder eine How-To wie man dieses einrichtet.
Ich würde gern einen Laptop, ein IPAD und ein Android Smartphone verbinden.

Kann mir jemand helfen?

Grüße
Zuletzt geändert von Coolio510 am 30. Sep 2019, 00:30, insgesamt 1-mal geändert.
Server 2016 Essentials mit Drive Bender:
MB: ASRock Z270 Taichi
CPU: Intel Core i5-6600 65W TDP
Speicher: 8GB Crucial DDR4-2400
LAN: Onboard Intel I219-V
Netzteil: SeaSonic SS-300ES 300W 80plus
Gehäuse: Fractal Design R5
SystemHDD: 250GB Samsung 960 Evo M.2 NVMe PCIe 3.0
PoolHDDs: 6x Seagate Ironwolf 8TB, 2x 4TB WD Green WD40EZRX

Coolio510
Foren-Mitglied
Beiträge: 51
Registriert: 11. Jan 2008, 17:22

Re: OpenVPN einrichten

Beitrag von Coolio510 » 30. Sep 2019, 00:30

Update:

Der Windows-eigene VPN kann wohl nur mit Windows-Clients.

Deshalb habe ich jetzt den Windows VPN deaktiviert und einen OpenVPN-Server installiert.
Ich bekommen sowohl vom Laptop als auch mit dem Android-Smartphone die Verbindung hergestellt.

Leider kann ich keinen Rechner in meinem Heimnetzwerk sehen, noch nicht einmal den Server selbst.
Ich kann auch keine IP in meinem Heimnetz anpingen.

Hat das schon jemand am laufen?

Grüße
Server 2016 Essentials mit Drive Bender:
MB: ASRock Z270 Taichi
CPU: Intel Core i5-6600 65W TDP
Speicher: 8GB Crucial DDR4-2400
LAN: Onboard Intel I219-V
Netzteil: SeaSonic SS-300ES 300W 80plus
Gehäuse: Fractal Design R5
SystemHDD: 250GB Samsung 960 Evo M.2 NVMe PCIe 3.0
PoolHDDs: 6x Seagate Ironwolf 8TB, 2x 4TB WD Green WD40EZRX

JoachimL
WHS-Experte
Beiträge: 1173
Registriert: 21. Sep 2009, 22:48

Re: OpenVPN einrichten

Beitrag von JoachimL » 30. Sep 2019, 19:26

Coolio510 hat geschrieben:
30. Sep 2019, 00:30
Leider kann ich keinen Rechner in meinem Heimnetzwerk sehen, noch nicht einmal den Server selbst.
Ich kann auch keine IP in meinem Heimnetz anpingen.
Das deutet darauf hin, dass Du keine Route konfiguriert hast. Kann man manuell auf dem Client machen oder Push Route auf dem VPN-Server konfigurieren.
Prüfen auf dem Windows-Client mit Kommandozeile und route print...
Gruß Joachim
WHS 2011 r.i.p. - Software die nicht mehr gewartet wird sollte man nicht mehr einsetzen.
Bei mir laufen drei Dell T20, teils mit Hyper-V-2016 (noch, 2019 in Planung), teils mit Windows 10 Pro. Einer läuft 7*24 und stellt u.a. Mailcow-Dockerized und einen Samba-Domain-Controller bereit. Klingt vielleicht seltsam, aber so ist das System mit Bitlocker verschlüsselt und kann vollständig und konsistent gesichert werden - beides sonst unter Linux schwierig bis unmöglich.
Die anderen dienen der Softwareentwicklung und als Backup-Server - eigene Software.
Fragen bitte nicht per PN sondern im Forum - dann haben andere auch was davon. Ich poste hier in meiner Freizeit, Ungeduld ist meiner Meinung nach fehl am Platz...

Coolio510
Foren-Mitglied
Beiträge: 51
Registriert: 11. Jan 2008, 17:22

Re: OpenVPN einrichten

Beitrag von Coolio510 » 3. Okt 2019, 09:16

Danke Joachim, das wars. Jetzt kann ich schon mal alle Rechner im Netz sehen.

Nun hat sich ein neues Problem ergeben. Ich kann auf den VPN-Server über die "Tunnel-IP" 10.10.10.1 auf den Server 2016 zugreifen.
Über die normale IP 192.168.178.2 kann ich zwar alles sehen, kann auch in Unterverzeichnisse rein, aber kann keine Datei öffnen oder kopieren??

Ich greife mit dem selben Nutzer aus beide IP-s zu also kann es ja nicht an den Rechten liegen oder?
Server 2016 Essentials mit Drive Bender:
MB: ASRock Z270 Taichi
CPU: Intel Core i5-6600 65W TDP
Speicher: 8GB Crucial DDR4-2400
LAN: Onboard Intel I219-V
Netzteil: SeaSonic SS-300ES 300W 80plus
Gehäuse: Fractal Design R5
SystemHDD: 250GB Samsung 960 Evo M.2 NVMe PCIe 3.0
PoolHDDs: 6x Seagate Ironwolf 8TB, 2x 4TB WD Green WD40EZRX

JoachimL
WHS-Experte
Beiträge: 1173
Registriert: 21. Sep 2009, 22:48

Re: OpenVPN einrichten

Beitrag von JoachimL » 3. Okt 2019, 10:44

Coolio510 hat geschrieben:
3. Okt 2019, 09:16
... Ich greife mit dem selben Nutzer aus beide IP-s zu also kann es ja nicht an den Rechten liegen oder?
OpenVPN läuft auf dem Server selbst, und der hat jetzt zwei IPs, 10.10.10.1 und 192.168.178.2 - richtig? Und mit der "HeimatIp" 192.168.178.2 geht weniger?
Also für unterschiedliche Rechte fallen mir zwei mögliche Ursachen ein:
  • Firewall - die kannst Du versuchsweise mal abschalten
  • Unterschiedliche Benutzer - das prüfst Du in Computer Management / Freigegebene Ordner / Sessions
Sonst wer eine Idee?
Gruß Joachim
WHS 2011 r.i.p. - Software die nicht mehr gewartet wird sollte man nicht mehr einsetzen.
Bei mir laufen drei Dell T20, teils mit Hyper-V-2016 (noch, 2019 in Planung), teils mit Windows 10 Pro. Einer läuft 7*24 und stellt u.a. Mailcow-Dockerized und einen Samba-Domain-Controller bereit. Klingt vielleicht seltsam, aber so ist das System mit Bitlocker verschlüsselt und kann vollständig und konsistent gesichert werden - beides sonst unter Linux schwierig bis unmöglich.
Die anderen dienen der Softwareentwicklung und als Backup-Server - eigene Software.
Fragen bitte nicht per PN sondern im Forum - dann haben andere auch was davon. Ich poste hier in meiner Freizeit, Ungeduld ist meiner Meinung nach fehl am Platz...

Coolio510
Foren-Mitglied
Beiträge: 51
Registriert: 11. Jan 2008, 17:22

Re: OpenVPN einrichten

Beitrag von Coolio510 » 3. Okt 2019, 18:08

Genau der Server hat Lokal die 192.168.178.2 und der VPN Tunnel hat die 10.10.10.1. und wenn ich per VPN verbunden bin kann ich auf beide IP-Adressen die gleichen Ordner sehen und auch in Unterordner rein. Nur Dateien öffnen, Kopieren oder löschen geht nur über 10.10.10.1.

Firewall deaktivieren hat keine Auswirkung.
Was kann ich in der Computerverwaltung überprüfen/sehen? Dort werden mir nur die aktuell verbundenen Nutzer angezeigt und da ich ja mit dem gleichen Nutzer auf die lokale sowie auf die VPN-IP zugreife ändert sich da ja nix, oder denk ich falsch?
Server 2016 Essentials mit Drive Bender:
MB: ASRock Z270 Taichi
CPU: Intel Core i5-6600 65W TDP
Speicher: 8GB Crucial DDR4-2400
LAN: Onboard Intel I219-V
Netzteil: SeaSonic SS-300ES 300W 80plus
Gehäuse: Fractal Design R5
SystemHDD: 250GB Samsung 960 Evo M.2 NVMe PCIe 3.0
PoolHDDs: 6x Seagate Ironwolf 8TB, 2x 4TB WD Green WD40EZRX

JoachimL
WHS-Experte
Beiträge: 1173
Registriert: 21. Sep 2009, 22:48

Re: OpenVPN einrichten

Beitrag von JoachimL » 3. Okt 2019, 19:46

Coolio510 hat geschrieben:
3. Okt 2019, 18:08
..., oder denk ich falsch?
Vielleicht. Und passiert jedem, auch mir!
Es gibt einen Unterschied zwischen den Berechtigungen Ordner sehen und Dateien öffnen - je nachdem wie das Share konfiguriert ist - google mal nach FolderEnumerationMode AccessBased...
Coolio510 hat geschrieben:
3. Okt 2019, 18:08
Dort werden mir nur die aktuell verbundenen Nutzer angezeigt und da ich ja mit dem gleichen Nutzer auf die lokale sowie auf die VPN-IP zugreife ändert sich da ja nix, oder denk ich falsch?
Vielleicht eben doch?
Kannst Du andere Geräte im Heimatnetz über das VPN pingen oder zugreifen?
Ansonsten fällt mir nichts ein. Bei mir laufen alle VPN-Einwahlpunkte unter Linux, OpenVPN ist nicht dabei, und einen 2016 hab ich auch nicht..
Gruß Joachim
WHS 2011 r.i.p. - Software die nicht mehr gewartet wird sollte man nicht mehr einsetzen.
Bei mir laufen drei Dell T20, teils mit Hyper-V-2016 (noch, 2019 in Planung), teils mit Windows 10 Pro. Einer läuft 7*24 und stellt u.a. Mailcow-Dockerized und einen Samba-Domain-Controller bereit. Klingt vielleicht seltsam, aber so ist das System mit Bitlocker verschlüsselt und kann vollständig und konsistent gesichert werden - beides sonst unter Linux schwierig bis unmöglich.
Die anderen dienen der Softwareentwicklung und als Backup-Server - eigene Software.
Fragen bitte nicht per PN sondern im Forum - dann haben andere auch was davon. Ich poste hier in meiner Freizeit, Ungeduld ist meiner Meinung nach fehl am Platz...

Coolio510
Foren-Mitglied
Beiträge: 51
Registriert: 11. Jan 2008, 17:22

Re: OpenVPN einrichten

Beitrag von Coolio510 » 4. Okt 2019, 08:10

Zugriffsbasierte Aufzählung würde aber doch dazu führen, dass ich den Inhalt gar nicht angezeigt bekomme wenn der User keine Rechte für den Zugriff hat. Der Share ist aber doch für meinen Benutzer mit vollen Rechten ausgestattet (Vollzugriff). Ich verstehe nicht wie es da einen Unterschied machen kann über welchen Weg ich auf den Server komme. Wenn ich über die Fritzbox per VPN ins Netzwerk gehe funktioniert der selbe Benutzer ja auf mit vollen Rechten.

Ich kann auf Fritzbox und PiHole per Browser zugreifen wie lokal auch. Pingen geht auf Fritzbox, PiHole und auf andere Windows PCs problemlos. Einen anderen SMB Share hab nicht, müsse ich erst einrichten.
Server 2016 Essentials mit Drive Bender:
MB: ASRock Z270 Taichi
CPU: Intel Core i5-6600 65W TDP
Speicher: 8GB Crucial DDR4-2400
LAN: Onboard Intel I219-V
Netzteil: SeaSonic SS-300ES 300W 80plus
Gehäuse: Fractal Design R5
SystemHDD: 250GB Samsung 960 Evo M.2 NVMe PCIe 3.0
PoolHDDs: 6x Seagate Ironwolf 8TB, 2x 4TB WD Green WD40EZRX

Antworten