NIC Teaming und WOL

Probleme oder Fragen zum Lights-Out Add-In unter allen Windows Plattformen werden hier beantwortet
Antworten
anderl1969
Foren-Mitglied
Beiträge: 232
Registriert: 18. Jun 2010, 11:49

NIC Teaming und WOL

Beitrag von anderl1969 » 10. Mai 2021, 19:12

Hallo,

ich habe auf meinen beiden HP Microservern Gen8, die ja jeweils insgesamt 3 LAN-Ports haben (1x Remote Management, 2x OS), NIC-Teaming nach LACP aktiviert. Der Switch ist ebenfalls LACP-fähig uns es funktioniert wie erhofft - mit einer Ausnahme: die Rechner lassen sich nicht mehr per WOL starten.
Auf dem Haupt-Server ist das unkritisch, da der 24/7 läuft. Auf dem ist allerdings LO installiert und der Backup-Server als LO-Client konfiguriert. Der Backup-Server soll nur zu bestimmten Zeiten gestartet werden, was nicht mehr funktioniert.

Mir ist bewusst, dass das kein LO Thema per se ist, aber vielleicht hat hier jemand Erfahrung damit, wie man unter NIC Teaming WOL wieder aktiviert bekommt.

gruß anderl
[+] Meine Server-Konfiguration
Home Server
System: HP ProLiant MicroServer Gen8 | Intel Xeon E3-1220L v2 | 2x HP DIMM 4 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x AData SP900 (SSD)
Data: Controller HPE Smart Array P222 | Logical RAID 5 12,0 TB | Physical 4x WD 40 EFRX 4,0 TB
OS: Server 2016 Essentials | Add-Ins: Lights Out

Backup-Server
System: HP ProLiant MicroServer Gen8 | Intel G1610T | 1x Kingston DIMM 8 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x Samsung 850 pro (SSD)
Data: Controller HPE Smart Array B120i | Physical 2x Hitachi Deskstar 5k300 2,0 TB + WD 80 EFZX 8,0 TB + WD 30 EFRX 3,0 TB
OS: Server 2016 Standard | Add-Ins: Lights Out

Benutzeravatar
Martin
Moderator
Beiträge: 9674
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: NIC Teaming und WOL

Beitrag von Martin » 10. Mai 2021, 19:54

Hast du mal probiert, ob sich der HP Gen8 mit einer einzelnen MAC wecken lässt? Das Team bekommt eine eigene, mit der es nicht funktioniert.
Ich lese die MAC-Adressen der einzelnen NICs aus, um sowas zu vermeiden. Evtl. klappt das bei LACP nicht.

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

anderl1969
Foren-Mitglied
Beiträge: 232
Registriert: 18. Jun 2010, 11:49

Re: NIC Teaming und WOL

Beitrag von anderl1969 » 10. Mai 2021, 23:52

Hallo Martin,

ja, ich habe alle 3 MAC-Addressen durchprobiert - die vom Team und auch die beiden der einzelnen NICs. Der Rechner ließ sich von keiner starten.
Aktuell habe ich beim Backup-Server das NIC Teaming wieder aufgelöst und WOL funktioniert wieder einwandfrei. ICh werde die nächsten Tage mal testen, wie es sich mit Teaming ohne LACP verhält.

gruß anderl
[+] Meine Server-Konfiguration
Home Server
System: HP ProLiant MicroServer Gen8 | Intel Xeon E3-1220L v2 | 2x HP DIMM 4 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x AData SP900 (SSD)
Data: Controller HPE Smart Array P222 | Logical RAID 5 12,0 TB | Physical 4x WD 40 EFRX 4,0 TB
OS: Server 2016 Essentials | Add-Ins: Lights Out

Backup-Server
System: HP ProLiant MicroServer Gen8 | Intel G1610T | 1x Kingston DIMM 8 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x Samsung 850 pro (SSD)
Data: Controller HPE Smart Array B120i | Physical 2x Hitachi Deskstar 5k300 2,0 TB + WD 80 EFZX 8,0 TB + WD 30 EFRX 3,0 TB
OS: Server 2016 Standard | Add-Ins: Lights Out

anderl1969
Foren-Mitglied
Beiträge: 232
Registriert: 18. Jun 2010, 11:49

Re: NIC Teaming und WOL

Beitrag von anderl1969 » 11. Mai 2021, 09:17

Es liegt tatsächlich an LACP in Verbindung mit meinem Zyxel Switch. Mit statischer Link Aggregation funktioniert WOL einwandfrei. Nachdem ich wusste, dass ich nach LACP und WOL googeln musste, habe ich auch sehr schnell die Bestätigung gefunden:

Laut LACP Spezifikation ist es wohl so, dass der Switch die LACP-Ports "blockt", wenn er keine LACP-Pakete an den entsprechenden Ports empfängt. Und genau das passiert, wenn das Gerät (also mein Backup-Server) runterfährt. Der Switch empfängt keine LACP-Pakete mehr und blockt den Port. Ist auch in der Zyxel KB als spezifikationskonformes Feature beschrieben: https://kb.zyxel.com/KB/searchArticle!g ... 39&lang=EN

Es mag wohl Switche geben, die das anders implementieren, aber bei meinem Zyxel ist das so :(

Vielen Dank nochmal an Martin dafür, dass er mich auf die richtige Spur gebracht hat.
[+] Meine Server-Konfiguration
Home Server
System: HP ProLiant MicroServer Gen8 | Intel Xeon E3-1220L v2 | 2x HP DIMM 4 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x AData SP900 (SSD)
Data: Controller HPE Smart Array P222 | Logical RAID 5 12,0 TB | Physical 4x WD 40 EFRX 4,0 TB
OS: Server 2016 Essentials | Add-Ins: Lights Out

Backup-Server
System: HP ProLiant MicroServer Gen8 | Intel G1610T | 1x Kingston DIMM 8 GB DDR3 ECC
Boot: Controller HPE Smart Array B120i | Physical 1x Samsung 850 pro (SSD)
Data: Controller HPE Smart Array B120i | Physical 2x Hitachi Deskstar 5k300 2,0 TB + WD 80 EFZX 8,0 TB + WD 30 EFRX 3,0 TB
OS: Server 2016 Standard | Add-Ins: Lights Out

Antworten