keine Verbindung von App zu Server von extern

Fragen und Probleme zur Lights-Out Mobile App unter iOS, Android und WP werden hier beantwortet
HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 13. Sep 2015, 12:49

Hallo,

ich hab das Problem, dass ich mich mit der App zwar zu Hause über das WLAN verbinden kann, aber nicht
extern über den Remotezugang, obwohl dieser eingerichtet ist und auch funktioniert.

Als Fehler erhalte ich immer, dass der Server nicht gefunden wurde
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 13. Sep 2015, 19:14

Welche Adresse hast du denn in der App hinterlegt? Das muss die öffentliche xxx.homeserversoftware.com sein.
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 13. Sep 2015, 19:28

ha - die vom Remotezugang, also <Name>.homeserver.com
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 14. Sep 2015, 15:29

Und die wird im Router von Port 443 auf 443 am Server weitergeleitet oder verwendest du da einen anderen Port?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 14. Sep 2015, 15:30

Und testest du das auch wirklich von ausserhalb? Manche Router haben Probleme bei Verwendung der externen Adresse im internen LAN.
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 14. Sep 2015, 17:28

ich route 443 auf Server

ich schalte bei meinem Eifon das WLAN aus und geh über die LTE-Verbindung
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 14. Sep 2015, 17:45

Und kannst du mit dem iPhone auf die normale https://xxx.homeserver.com Webseite (also mit SSL) zugreifen?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 14. Sep 2015, 17:52

mit der Google Chrome App ja
mit Safari nein
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 14. Sep 2015, 18:01

Hm, warum nicht mit Safari? Was kommt da für eine Meldung?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 14. Sep 2015, 18:10

Server antwortet nicht
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 15. Sep 2015, 07:30

Und welchen Fehlercode bekommst du in Lights-Out Mobile?
Kannst du mir mal einen Screenshot deiner Serverparameter aus Lights-Out Mobile machen?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 15. Sep 2015, 20:02

Fehlercode: 404

Screenshot kommt per PN
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 17. Sep 2015, 10:28

Hm, 404 bedeutet dass er den Endpunkt nicht findet. Eventuell stimmt mit deiner Adresszuordnung oder URL etwas nicht. Könntest du mir einen Testzugang anlegen und mir die Benutzerdaten per PM zukommen lassen?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

Benutzeravatar
Martin
Moderator
Beiträge: 9593
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: keine Verbindung von App zu Server von extern

Beitrag von Martin » 17. Sep 2015, 10:28

ESET hat seine Finger da auch nicht drin?
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

HelmiMUC
Foren-Mitglied
Beiträge: 216
Registriert: 20. Jan 2012, 19:20

Re: keine Verbindung von App zu Server von extern

Beitrag von HelmiMUC » 17. Sep 2015, 18:42

habs jetzt wieder mal probiert und da hats echt mal geklappt
aber ich hatte schon die o. g. Probleme bei meinen Tests

Kann ich irgendwie selbst prüfen, ob die Adresszuordnung stimmt, wenn es wieder auftritt?
mfg
Helmi

---------------------------------------------------------------------------
Acer H431 HomeServer mit Windows Home Server V1

Virenscanner: ESET NOD 32 antivirus V9

Antworten