Balancing die 2te mit Bitte um Feedback

Allgemeine Fragen zu Windows Home Server
Antworten
bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 20. Okt 2007, 09:16

Hallo zusammen,
ich muss das Thema mit den ständig arbeitenden Festplatten einfach nochmal
aufgreifen, es lässt mir keine Ruhe.
Ich würde gerne wissen ob das bei mir jetzt ein Einzalfall ist oder ob
die meisten dieses Problem mit dem ständigen "Speicher wird ausgeglichen" haben.
Es kann doch nicht sein dass ohne grössere Kopiervorgänge und gerademal 3,3 GB an
duplizeirten Ordnern die Festplatten tagelang ununterbrochen rödeln,
wie lange werden sie das wohl durchhalten?!?

Wäre nett wenn Ihr Eure Erfahrungen in diesem bereich hier posten könntet und wie häufig und wie lange der WHS
bei Euch "ausbalanziert", bzw. wie es allgemein mit der Festplattenaktivität und Performance aussieht.


Gruß,
Stephan
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

Benutzeravatar
Martin
Moderator
Beiträge: 9734
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von Martin » 20. Okt 2007, 09:40

Hallo Stephan,

ich denke es ist nicht normal. In meinem WHS (Sig) sind von 1,14TB noch 68% frei.
Ausgleichsvorgänge liegen beim Kopieren neuer Dateien im Bereich von Minuten.

Hast Du mal die Logfiles in
C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Windows Home Server\logs
überprüft?

Und wie stark sind deine Datenträger fragmentiert?

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

eclere
Foren-Mitglied
Beiträge: 88
Registriert: 10. Sep 2007, 01:12

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von eclere » 20. Okt 2007, 10:20

Hallo,

ich hatte das Problem auch. Bei mir waren von 2TB etwa 50% belegt, was auf dem Server zu starker CPU Auslastung führte (kontinuierlich 40-50%). Angeblich soll das Chip in einer ihrer letzten Ausgabe bemängelt haben, ich habe den Bericht aber nicht gelesen.

Weiterhin scheint der Prozess, welcher die hohe Last verursacht, gleichzeitig für die Freigaben verantwortlich zu sein, so dass deren Verfügbarkeit für mich nicht mehr akzeptabel war. Ein Normaler Win2003 antwortet bei den Freigaben nach meinem Empfinden 2-3 mal schneller.

Gruß Thorsten

Benutzeravatar
AliG
Moderator
Beiträge: 3724
Registriert: 6. Jun 2007, 17:33
Wohnort: Salzburg, Österreich

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von AliG » 20. Okt 2007, 15:05

Also ich hab auch keine Probleme mit dem ausgleichen des Speichers, d.h. wenn ich neue Daten kopiere, dauert es so lange wie es eben dauert um die Daten auf die andere Festplatte zu kopieren, dann ist der Speicher aber wieder "ausgeglichen".

lg Alex
Mache ich etwas richtig, merkt es keiner. Mache ich etwas falsch, vergisst es keiner. :D

Mein WHS

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 20. Okt 2007, 22:48

Also nachdem ich dieses Problem tagelang hatte habe ich mal die Testversion von
Diskeeper installiert. Den habe ich jetzt schon einige Tage drauf und daher ist die
Fragmentierung der Platten praktisch gleich Null, aber dadurch ist es auch nicht besser geworden.

Zu den Logfiles:

Da sind ja ohne Ende drin,
welche wären da interessant?
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 20. Okt 2007, 23:01

Was sich im Logfile qsm immer wiederholt ist sowas:

ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\{0FA9A58D-8EA8-4A03-84A5-F3CBE4AE325B}.C.FileRecordHash.4096.dat]
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

Benutzeravatar
Martin
Moderator
Beiträge: 9734
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von Martin » 20. Okt 2007, 23:06

Das ist eines der Backupfiles. Vielleicht macht es Sinn mal alle Backups zu löschen?
Geht am einfachsten mit dem Toolkit.

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 20. Okt 2007, 23:33

Hab egerade noch was anderes in der q_de.log gefunden.
Scheinbar hat er ein Problem mit einem zu langen Verzeichnispfad in einer der Freigaben.
Habe das Verzeichnis jetzt mal gepackt mal abwarten,
wenn das nicht genutzt hat werde ich mal alle Backups löschen.

EDIT:
Ich beobachte gerade die Datenträgerverwaltung und sehe daß sich der freie Speicherplatz
auf den Platten ändert, er macht also was.
Ich gebe ihm noch ein bisschen Zeit.
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

Benutzeravatar
Martin
Moderator
Beiträge: 9734
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von Martin » 21. Okt 2007, 16:50

bitrider hat geschrieben: Scheinbar hat er ein Problem mit einem zu langen Verzeichnispfad in einer der Freigaben.
Dazu gabs hier eine Diskussion:
viewtopic.php?f=9&t=534

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 21. Okt 2007, 18:46

Das Problem habe ich mittlerweile gelöst.
Ab und zu sehe ich jetzt auch mal für ein paar Minuter "Speicher ausgeglichen".
Aber irgendwas anderes muss da noch im Busch sein.

Hier mal ein Auszug aus dem q_de.log,
kann mir jemand sagen ob das bei euch auch so aussieht?

MIGR: 10/21/2007 16:03:18:618: Completed 300 migration passes.
MIGR: 10/21/2007 16:33:18:728: Beginning full migration pass. LazyPass is True.
MIGR: 10/21/2007 16:39:14:212: Ended full migration pass.
MIGR: 10/21/2007 16:39:15:400: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 17:03:22:775: Ended full migration pass.
MIGR: 10/21/2007 17:13:22:884: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 17:40:30:056: Ended full migration pass.
MIGR: 10/21/2007 17:57:04:618: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 17:57:09:275: Ended full migration pass.
MIGR: 10/21/2007 17:57:19:696: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:00:00:087: Ended full migration pass.
MIGR: 10/21/2007 18:00:00:196: Beginning full migration pass. LazyPass is False.
REBL: 10/21/2007 18:00:40:290: Starting rebalance pass for primary volume.
MIGR: 10/21/2007 18:20:00:900: Ended full migration pass.
MIGR: 10/21/2007 18:20:11:650: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:22:08:462: Ended full migration pass.
MIGR: 10/21/2007 18:22:29:337: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:22:34:962: Ended full migration pass.
MIGR: 10/21/2007 18:22:49:806: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:22:53:821: Ended full migration pass.
MIGR: 10/21/2007 18:23:04:353: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:26:04:040: Ended full migration pass.
MIGR: 10/21/2007 18:26:14:415: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:28:12:212: Ended full migration pass.
MIGR: 10/21/2007 18:28:27:962: Completed 325 migration passes.
MIGR: 10/21/2007 18:28:28:400: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:28:30:196: Ended full migration pass.
MIGR: 10/21/2007 18:28:52:493: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:32:30:446: Ended full migration pass.
MIGR: 10/21/2007 18:32:40:900: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:34:10:446: Ended full migration pass.
MIGR: 10/21/2007 18:34:26:306: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:34:29:775: Ended full migration pass.
MIGR: 10/21/2007 18:35:03:728: Beginning full migration pass. LazyPass is False.
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

Benutzeravatar
Martin
Moderator
Beiträge: 9734
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von Martin » 21. Okt 2007, 19:56

Meine q_de.log:

MIGR: 10/21/2007 16:53:56:140: Ended full migration pass.
MIGR: 10/21/2007 17:07:38:328: Beginning full migration pass. LazyPass is False.
CORE: 10/21/2007 17:07:39:281: Entering auto-throttle mode. Queue = 3. Sleep time (file) = 5000. Sleep time (directory) = 10000.
CORE: 10/21/2007 17:07:44:296: Leaving auto-throttle mode
MIGR: 10/21/2007 17:09:05:406: Ended full migration pass.
MIGR: 10/21/2007 17:19:05:515: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 17:20:37:093: Ended full migration pass.
MIGR: 10/21/2007 17:49:22:093: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 17:50:51:046: Ended full migration pass.
MIGR: 10/21/2007 18:00:00:187: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:01:29:125: Ended full migration pass.
MIGR: 10/21/2007 18:11:29:281: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:12:57:265: Ended full migration pass.
MIGR: 10/21/2007 18:42:58:031: Beginning full migration pass. LazyPass is True.
MIGR: 10/21/2007 18:42:58:062: Leaving lazy pass mode for file D:\folders\{378AE094-F4CA-4D9B-BDA5-649D6F738276}\whs.reg
MIGR: 10/21/2007 18:44:25:718: Ended full migration pass.
MIGR: 10/21/2007 18:49:25:828: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 18:50:52:109: Ended full migration pass.
MIGR: 10/21/2007 18:50:52:109: Completed 775 migration passes.
MIGR: 10/21/2007 19:00:52:406: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 19:02:21:468: Ended full migration pass.
MIGR: 10/21/2007 19:32:22:281: Beginning full migration pass. LazyPass is True.
MIGR: 10/21/2007 19:32:22:312: Leaving lazy pass mode for file D:\folders\{378AE094-F4CA-4D9B-BDA5-649D6F738276}\whs.reg
MIGR: 10/21/2007 19:33:48:000: Ended full migration pass.
MIGR: 10/21/2007 19:38:48:140: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 19:40:16:859: Ended full migration pass.
MIGR: 10/21/2007 19:50:16:968: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 19:50:47:640: Ended full migration pass.
MIGR: 10/21/2007 19:51:03:812: Beginning full migration pass. LazyPass is False.
MIGR: 10/21/2007 19:51:04:984: Ended full migration pass.
MIGR: 10/21/2007 19:51:21:140: Beginning full migration pass. LazyPass is False.

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 21. Okt 2007, 20:10

Hmmm,
sieht ja alles sehr ähnlich aus.
Kann jetzt in den Logs auch keine anderen fehler mehr finden.
Nur das hier, aber das war zum Zeitpunkt des Backups, denke das kommt daher daß die Dateien dann gesperrt sind.
Kannst Du mal bitte nachschauen ob sowas bei Dir auch zum Zeitpunkt der Backups vorkommt (qsm.xxx.log)

Bin langsam ratlos wieso das Ding so oft und lange ausgleicht ohne daß etwas kopiert wurde.

[21.10.2007 13:44:38 bbc] QSM Global Status: Speicher wird ausgeglichen...

[21.10.2007 13:44:38 bc8] QSM Global Status: Speicher wird ausgeglichen...

ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\Control.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\Data.4096.4.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\GlobalCluster.4096.dat]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\GlobalClusterLatest.4096.dat]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\GlobalClusterLatest.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\R65VISTA.C.FileRecordHash.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\R65VISTA.C.VolumeCluster.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\R65VISTA.C.VolumeClusterLatest1.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\R65VISTA.C.VolumeClusterLatest2.4096.new]
ERROR: Migrator reported FileError for file [D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4}\{BDBCBE11-DC7B-49DE-839C-51967B1A8787}.tmp]
[21.10.2007 13:45:10 bbc] Refresh Status Line in UI
GlobalEvent started
ComputeAdviseArray started
ComputeAdviseArray ended (2)
GlobalEvent ended
DEMigration: Full pass started. Error count reset to 0
[21.10.2007 13:45:10 bc8] UpdateStatusLine 1
GlobalEvent started
ComputeAdviseArray started
ComputeAdviseArray ended (2)
GlobalEvent ended
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

Benutzeravatar
Martin
Moderator
Beiträge: 9734
Registriert: 11. Sep 2007, 10:51
Wohnort: Im wilden Süden

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von Martin » 21. Okt 2007, 22:35

Ja, das sieht bei mir auch so aus.

Gruß
Martin
Eigenbau mit WSE 2012 R2, HP N40L mit WSE 2012 R2 als Backupserver, HP Microserver Gen8 unter WSE 2016
Entwickler von Lights-Out

bitrider
Foren-Mitglied
Beiträge: 68
Registriert: 9. Okt 2007, 10:01

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von bitrider » 22. Okt 2007, 07:56

OK, danke.

Nach der Beseitigung des Problems mit den zu langen Pfaden ist es auch etwas besser geworden,
aber zufriedenstellend ist das für mich nicht.
Das Ding verursacht mir einfach viel zu viel Festplattenaktivität,
und da der WHS ja eigentlich vorbildlich einfach zu handhaben sein sollte,
denke ich muß MS noch etwas nachlegen damit man nicht in zig tausend Zeilen langen Logs nach
möglichen Fehlerursachen suchen muss.
Ich stelle mir so eine Art Problem- und Diagnoscenter in der Console vor,
wo mögliche Probleme aufgelistet werden und evtl. einen Lösungsvorschlag gemacht wird.

Ich kann nur hoffen, daß Microsoft in nächster Zeit
ein Update rausbringt welches die Festplatten etwas schont.

Danke nochmal für Deine Hilfe
Gehäuse: CoolerMaster Centurion RC 534
CPU: Intel Core 2 Duo E4400 (2GHz)
RAM: 2 x 512 MB Infineon CL5 PC 6400/800 MHz,
MB: Gigabyte GA-P35C_DS3R
Sys: Seageate IDE 250 GB
Daten: 3 X 500 GB (Samsung HD501LJ)
Ext: 1 x 300 GB Extern (not added)

pleibling
Foren-Mitglied
Beiträge: 389
Registriert: 22. Jul 2007, 16:23

Re: Balancing die 2te mit Bitte um Feedback

Beitrag von pleibling » 26. Okt 2007, 08:56

ich habe das mit der festplatten auslastung bei mir ebenfalls beobachten können, die platten die ich in dem whs verwende waren alle komplett neu - jetzt bekomme ich immer wieder angezeigt das sys volume und auch gelegentlich eine andere hdd fehlerhaft sind. aber laut hdd health sind die platten ok.

wenn ich den server dann neustarte ist es wieder für ein paar stunden oder wenn ich glück habe für ein paar tage ok.

in den logs habe ich noch nicht gesehen, werde ich aber auch mal kontrollieren. dazu werde ich auch mal alle backups löschen und das mal ein paar tage beobachten.

Antworten