Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Allgemeine Fragen zu Windows Home Server
Antworten
doubleyou
Foren-Mitglied
Beiträge: 70
Registriert: 7. Jun 2009, 16:43
Wohnort: München

Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von doubleyou » 2. Mai 2017, 11:03

Hallo Beisammen,
nach Erweitung der Festplattenspeichers um 2 TB durch Austausch von zwei 1 TB durch zwei 2 TB (siehe hier funtkioniert die automatische Datensicherung nicht mehr.
Ich kann auf alle Verzeichnisse zugreifen, sowohl auf dem Server wie auch dem Laptop, mit dem ich arbeite und der zu sichern ist. Es erscheint die bekannte Meldung "Sicherungstatus: (0% abgeschlossen) - Bei der Sicherung ist ein Fehler aufgetreten, da der Computer keinen Volumesnapshot erstellen konnte. Um dieses Problem zu beheben, fühen Sie "chkdsk /f /r" für die einzelnen Festpaltten [hier bricht die Meldung ab]" Es fehlt der Teil der Meldung, welche Festplatten -die auf dem Server oder die auf dem zu sichernden Gerät - dem "chkdsk /f /r " zu unterziehen sind. Das zu sichernde Gerät hat eine SSD mit 1 TB - da bringt chkdsk wohl nichts ...

Die SSD ist aufgeteilt einen System-Partiton und eine Datenpartition. In der Datenpartition befindet sich eine MyDrive.vhd (die ich von der Datensicherung ausgeschlossen habe), wobei der sich darin befindliche virtuelle MyDrive gemappt ist auf einen Laufwerksbuchstaben (F:). Den Inhalt von F: lasse ich mitsichern. Hat so auch funktioniert (bis der Platzmangel eine weitere Datensicherung verhinderte).

Für hilfreiche Hinweise wäre ich sehr dankbar!
Beste Grüße!
Acer H340 mit 2 x WD Blue WD20EZRZ 2 TB; 1 x WDC WD20 (2TB), 1 x WD20EZRX Green 2TB
Windows Home Server Konsole: 6.0.2423.0
Windows Home Server Sichern und Wiederherstellen: 6.0.2423.0
Windows Home Server Laufwerkextender: 6.0.2423.0
Windows Home Server Remotezugriff: 6.0.3436.0
Windows Home Server Speicher-Manager: 6.0.3039.0

1 Client W7 Prof. 64, 1 Client Win 8.1Prof 64, 1 Surface Pro Win 10; Fritzbox 7390,2 x HP Procurve Swich für den Stern und auf den Stockwerken

Benutzeravatar
Nobby1805
Moderator
Beiträge: 20727
Registriert: 6. Jun 2009, 17:40
Wohnort: Essen

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von Nobby1805 » 2. Mai 2017, 13:18

Eigentlich kann das mit deiner Austauschaktion nichts zu tun haben weil sich dieser Fehler nicht auf den Server sondern auf ein Problem des Clients bezieht ... es sei denn, bei der Umstellung ist etwas schief gelaufen, darum auch meine Bitte im anderen Thread auf jeden Fall WHSDisks laufen zu lassen und das Ergebnis zu posten.

Warum sollte ein CHKDSK auf einer SSD nichts bringen, Datenstrukturen des File-Systems können auch dort inkonsistent werden. Um genau zu sehen wann, bzw. bei welcher Partition, das Problem aufgetreten ist musst du in den Logfile schauen ... auf dem Client im Verzeichnis C:\ProgramData\Microsoft\Windows Home Server\logs die neueste Version von BackupEngine....log
WHS: Acer H340 mit 2x 1 TB (WD10EAVS), 2x 2 TB (WD20EARS), PP3+UR2
5 Clients:
1 Intel i5-4670K, ASUS H87-PRO, 16 GB, 250 GB SSD, 2x 500 GB, Win 10 Pro x64 1709
1 Lüfterlos fürs Wohnzimmer, Intel Celeron D 1900, 4 GB, 240 GB, Win 10 Pro x64 1709
1 HP G 5230, Win 10 Pro 1703
1 Sony Vaio EB 2H4E, Win7 Home Prem. x64 (bleibt auf W7 weil Sony keine W10-Grafiktreiber anbietet :cry: )
1 Samsung NP-R540-JS09DE, Win 10 Pro x64 1709


WHSListTombstones, ein Tool zur Auflistung aller Tombstones
WHSDisks, ein Tool zur Darstellung und Prüfung der DriveExtender-Konfiguration
WHSDiskNames, ein Tool zur Änderung der Plattennamen in der Konsole
WHSBackup, Infos und Tool zur Backup-DB (2011-Version (auch für WSE2012))
Bitte schreibt bei Fragen und Problemen eure Konfig in die Signatur

doubleyou
Foren-Mitglied
Beiträge: 70
Registriert: 7. Jun 2009, 16:43
Wohnort: München

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von doubleyou » 4. Mai 2017, 06:57

... ich schon wieder.
Nachdem die Platten-im Server-Probleme gelöst sind geht es weiter mit dem Sicherungsproblem.
Habe gestern Abend die Sicherung meines W10-Desktop angestoßen. Nach 9% Abbruch:
9ProzAbbruch.JPG
9ProzAbbruch.JPG (22.01 KiB) 1316 mal betrachtet
Im BackupEngine.170503.2215388194.9776.log auf dem Client (von 22:40) steht:
[1]170503.221613.1773: Status: Volume (shadow) size 244620193792 used 121286791168
[1]170503.221638.0756: Status: File records: 243291 sent, 41310 changed, 19 metadata, 227129 received (bytes sent=4849564 received=4535379)
[1]170503.221638.0814: Status: Prepare fixups: total restore size 172586528768
[1]170503.221639.1342: Status: Determine changed: scan 8617847 size 35298701312
[1]170503.222701.8577: Status: Determine changed: scanned 8617847 of 26246338 total with 4 fixups (bytes sent=180850794 received=0)
[1]170503.223824.8439: Status: Server phase Reorganize1 complete
[1]170503.223824.8439: Status: Send changed: 1877559 requested of 8617847 total
[1]170503.223842.6733: Error: ReconnectableStream: Write catch IOException In die Übertragungsverbindung können keine Daten geschrieben werden: Eine vorhandene Verbindung wurde vom Remotehost geschlossen., generation 1, reconnect
[1]170503.223843.8453: Error: ReconnectableStream: TryReconnect catch SocketException Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte 192.168.178.5:8912, generation 2, reconnect
[1]170503.223843.8453: Error: ReconnectableStream: reconnect attempt failed, waiting
[vorstehendes wiederholt sich dann viele Male, es folgt dann:]
[1]170503.224003.1947: Error: ReconnectableStream: Received ReconnectSessionFailed
[1]170503.224003.2103: Error: ReconnectableStream: TryReconnect catch FatalProtocolException 'Reconnect attempt rejected by server', generation 2, fatal
bei Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.TryReconnect(Int32 localGeneration)
[1]170503.224006.2574: Error: ReconnectableStream: Flush catch IOException In die Übertragungsverbindung können keine Daten geschrieben werden: Eine vorhandene Verbindung wurde vom Remotehost geschlossen., generation 2, reconnect
[1]170503.224006.6637: Error: ReconnectableStream: Received ReconnectSessionFailed
[1]170503.224006.6637: Error: ReconnectableStream: TryReconnect catch FatalProtocolException 'Reconnect attempt rejected by server', generation 3, fatal
bei Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.TryReconnect(Int32 localGeneration)
[1]170503.224006.6637: Status: Exception: ClientException
[1]170503.224006.6637: Status: : ProtocolException
[1]170503.224006.6637: Status: : Client / Server connection lost
[1]170503.224006.6637: Status: : bei Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.TryReconnect(Int32 localGeneration)
bei Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.WriteWithReconnect(Int32 count)
bei Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.Write(Byte[] buffer, Int32 offset, Int32 count)
bei Microsoft.HomeServer.Common.Client.BinaryWriterEx.Write(Byte[] value, Int32 offset, Int32 length)
bei Microsoft.HomeServer.Backup.Protocol.BackupProtocol.SendClusterData(Int64 clusterIndex, Byte[] data, Int32 offset, Int32 length)
bei Microsoft.HomeServer.Backup.BackupOp.BackupOperation.DoClusterPass2()
bei Microsoft.HomeServer.Backup.BackupOp.BackupOperation.RunWithoutCatch()
bei Microsoft.HomeServer.Backup.BackupOp.BackupOperation.Run()
bei Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.RunWithoutCatch()
bei Microsoft.HomeServer.Backup.BackupOp.BackupSetOperation.Run()
[1]170503.224006.6637: Status: Bytes sent=321275575, bytes received=4552074, 2 reconnects
Server und Cleint liefen die ganze Nacht durch - seltsam.
Ich starte die Datensicherung nocheinmal, mal sehen was passiert ...
Acer H340 mit 2 x WD Blue WD20EZRZ 2 TB; 1 x WDC WD20 (2TB), 1 x WD20EZRX Green 2TB
Windows Home Server Konsole: 6.0.2423.0
Windows Home Server Sichern und Wiederherstellen: 6.0.2423.0
Windows Home Server Laufwerkextender: 6.0.2423.0
Windows Home Server Remotezugriff: 6.0.3436.0
Windows Home Server Speicher-Manager: 6.0.3039.0

1 Client W7 Prof. 64, 1 Client Win 8.1Prof 64, 1 Surface Pro Win 10; Fritzbox 7390,2 x HP Procurve Swich für den Stern und auf den Stockwerken

Benutzeravatar
Nobby1805
Moderator
Beiträge: 20727
Registriert: 6. Jun 2009, 17:40
Wohnort: Essen

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von Nobby1805 » 4. Mai 2017, 09:28

Wenn ich mir den Screenshot, diesen Text als Fehlergrund habe ich übrigens noch nie gesehen, und die Meldungen im Log ansehen tippe ich mal auf 3 Platten im Client ...
Falls auch der erneute Versuch nicht klappt poste bitte den kompletten Log und auch den zugehörigen (1 Log pro Tag) backup.log vom WHS
WHS: Acer H340 mit 2x 1 TB (WD10EAVS), 2x 2 TB (WD20EARS), PP3+UR2
5 Clients:
1 Intel i5-4670K, ASUS H87-PRO, 16 GB, 250 GB SSD, 2x 500 GB, Win 10 Pro x64 1709
1 Lüfterlos fürs Wohnzimmer, Intel Celeron D 1900, 4 GB, 240 GB, Win 10 Pro x64 1709
1 HP G 5230, Win 10 Pro 1703
1 Sony Vaio EB 2H4E, Win7 Home Prem. x64 (bleibt auf W7 weil Sony keine W10-Grafiktreiber anbietet :cry: )
1 Samsung NP-R540-JS09DE, Win 10 Pro x64 1709


WHSListTombstones, ein Tool zur Auflistung aller Tombstones
WHSDisks, ein Tool zur Darstellung und Prüfung der DriveExtender-Konfiguration
WHSDiskNames, ein Tool zur Änderung der Plattennamen in der Konsole
WHSBackup, Infos und Tool zur Backup-DB (2011-Version (auch für WSE2012))
Bitte schreibt bei Fragen und Problemen eure Konfig in die Signatur

doubleyou
Foren-Mitglied
Beiträge: 70
Registriert: 7. Jun 2009, 16:43
Wohnort: München

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von doubleyou » 4. Mai 2017, 09:53

Danke Nobby,
die erneute Sicherung lief komplett durch - der 'Härtetest' kommt wenn ich am Wochenende die Sciherung des Laptop versuche. Bis dahin gebe ich ersteinmal Ruhe ...
Beste Grüße und einen schönen Tag noch!
Acer H340 mit 2 x WD Blue WD20EZRZ 2 TB; 1 x WDC WD20 (2TB), 1 x WD20EZRX Green 2TB
Windows Home Server Konsole: 6.0.2423.0
Windows Home Server Sichern und Wiederherstellen: 6.0.2423.0
Windows Home Server Laufwerkextender: 6.0.2423.0
Windows Home Server Remotezugriff: 6.0.3436.0
Windows Home Server Speicher-Manager: 6.0.3039.0

1 Client W7 Prof. 64, 1 Client Win 8.1Prof 64, 1 Surface Pro Win 10; Fritzbox 7390,2 x HP Procurve Swich für den Stern und auf den Stockwerken

doubleyou
Foren-Mitglied
Beiträge: 70
Registriert: 7. Jun 2009, 16:43
Wohnort: München

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von doubleyou » 7. Mai 2017, 15:15

Hallo Nobby,
wie versprochen am Wochenende die Datensicherung des Laptop versucht. Über die WHS-Konsole gestartet blieb sie bei 0% hängen.
In der Ereignisanzeige des WHS kommt folgende Fehlermeldung:
NLB-Cluster 0.0.0.0 : Aufgrund von Parameterfehlern kann der Clustermodus nicht aktiviert werden. Der gesamte Datenverkehr verläuft über TCP/IP. Beheben Sie das Problem, und starten Sie dann den Clusterbetrieb mit dem Befehl "wlbs reload" gefolgt von "wlbs start" erneut.
Im cmd-Fenster wird auf "Wwlbs reload" folgende Meldung ausgegegeben:
Beim Abfragen der Parameter in der Registrierung ist ein Fehler aufgetreten. Weitere Informationen finden Sie im Ereignisprotokoll auf dem Zielhost.

Unter C:\Users\All Users\Microsoft\Windows Home Server\logs auf dem Zielhost fand ich dann BackupEngine.170507.1151288237.23640.log, die um 12:01 - dem Zeitpunkt, als ich wlbs reload aufrief - angelegt wurde. Ich füge sie hier an:
BackupEngine.170507.1151288237.23640.log
Log-Datei
(2.59 KiB) 23-mal heruntergeladen


Wie bereits beschrieben ist die zu sichernde SSD auf dem Laptop aufgeteilt in eine System-Partiton (C:), und eine Datenpartition (D:). In der Datenpartition befindet sich eine MyDrive.vhd (die ich von der Datensicherung ausgeschlossen habe), wobei der sich darin befindliche virtuelle MyDrive auf den Laufwerksbuchstaben F: gemappt ist. Den Inhalt von F: lasse ich mitsichern. Das sieht in der Sicherungskonfiguration so aus:
Bild

Mein nächster Versuch bestand dann darin, zunächst allein D:, dann D: und C: und schließlich C:, D: und F: zu sichern. Bei den ersten beiden - also auch die Sicherung von C: und D: (unter Ausschluss der VHD-Datei) hat es geklappt, jedoch bei dem Versuch: F: zu sichern kommt wieder der gleiche Fehler
BackupEngine.170507.1457280304.6776.log
(1.7 KiB) 20-mal heruntergeladen
.
Ich füge auch das Log von der WHS bei.
backup-050717.log
(383.64 KiB) 32-mal heruntergeladen

Der Hinweis in der Ereignisanzeige ist einzigartig hilfreich: "Beheben Sie das Problem". Wie denn?
Herzlichen Dank für Deine Hilfe
Dateianhänge
zusicherndeV.JPG
Zu sichernde Dateien
zusicherndeV.JPG (42.05 KiB) 1244 mal betrachtet
Acer H340 mit 2 x WD Blue WD20EZRZ 2 TB; 1 x WDC WD20 (2TB), 1 x WD20EZRX Green 2TB
Windows Home Server Konsole: 6.0.2423.0
Windows Home Server Sichern und Wiederherstellen: 6.0.2423.0
Windows Home Server Laufwerkextender: 6.0.2423.0
Windows Home Server Remotezugriff: 6.0.3436.0
Windows Home Server Speicher-Manager: 6.0.3039.0

1 Client W7 Prof. 64, 1 Client Win 8.1Prof 64, 1 Surface Pro Win 10; Fritzbox 7390,2 x HP Procurve Swich für den Stern und auf den Stockwerken

Benutzeravatar
Nobby1805
Moderator
Beiträge: 20727
Registriert: 6. Jun 2009, 17:40
Wohnort: Essen

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von Nobby1805 » 7. Mai 2017, 16:21

und die Sicherung von F hat auf diese Art und Weise schon mal funktioniert?
Welche Windows Version läuft denn auf dem Laptop? Hast du da etwas verändert seitdem die letzte Sicherung funktioniert hat?

Das Problem liegt definitiv auf dem Laptop!! Wenn ich nach dem Fehlercode im BackupEngine-Log suche ... dann finde ich:

VSS_E_NESTED_VOLUME_LIMIT0x8004232CL
The specified volume is nested too deeply to participate in the VSS operation. Possible reasons for this error include the following:
•Trying to create a shadow copy of a volume that resides on a VHD that is contained in another VHD.
•Trying to create a shadow copy of a VHD volume when the volume that contains the VHD is also in the same shadow copy set.

demnach kann es gar nicht funktionieren (2. Spiegelpunkt)
WHS: Acer H340 mit 2x 1 TB (WD10EAVS), 2x 2 TB (WD20EARS), PP3+UR2
5 Clients:
1 Intel i5-4670K, ASUS H87-PRO, 16 GB, 250 GB SSD, 2x 500 GB, Win 10 Pro x64 1709
1 Lüfterlos fürs Wohnzimmer, Intel Celeron D 1900, 4 GB, 240 GB, Win 10 Pro x64 1709
1 HP G 5230, Win 10 Pro 1703
1 Sony Vaio EB 2H4E, Win7 Home Prem. x64 (bleibt auf W7 weil Sony keine W10-Grafiktreiber anbietet :cry: )
1 Samsung NP-R540-JS09DE, Win 10 Pro x64 1709


WHSListTombstones, ein Tool zur Auflistung aller Tombstones
WHSDisks, ein Tool zur Darstellung und Prüfung der DriveExtender-Konfiguration
WHSDiskNames, ein Tool zur Änderung der Plattennamen in der Konsole
WHSBackup, Infos und Tool zur Backup-DB (2011-Version (auch für WSE2012))
Bitte schreibt bei Fragen und Problemen eure Konfig in die Signatur

doubleyou
Foren-Mitglied
Beiträge: 70
Registriert: 7. Jun 2009, 16:43
Wohnort: München

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von doubleyou » 8. Mai 2017, 11:43

Nobby1805 hat geschrieben:
7. Mai 2017, 16:21
und die Sicherung von F hat auf diese Art und Weise schon mal funktioniert?
Welche Windows Version läuft denn auf dem Laptop? Hast du da etwas verändert seitdem die letzte Sicherung funktioniert hat?
Ja, das ganze Jahr bis in den April hinein, jedoch vor der Erweiterung der Homeserver. Am Laptop hatte ich seit Januar nichts veränmdert. Der Laptop läuft unter Windoof 8.1, die vhd wurde unter Nutzung des Workplace Protect Tool von Fujitsu im Dezember 2016 anlässlich des Tausches der Festplatte im Laptop angelegt. Davor befand sich die vhd-Datei auch auf D:, aber an anderer Stelle.
Nobby1805 hat geschrieben:
7. Mai 2017, 16:21
Das Problem liegt definitiv auf dem Laptop!! Wenn ich nach dem Fehlercode im BackupEngine-Log suche ... dann finde ich:

VSS_E_NESTED_VOLUME_LIMIT0x8004232CL
The specified volume is nested too deeply to participate in the VSS operation. Possible reasons for this error include the following:
•Trying to create a shadow copy of a volume that resides on a VHD that is contained in another VHD.
•Trying to create a shadow copy of a VHD volume when the volume that contains the VHD is also in the same shadow copy set.

demnach kann es gar nicht funktionieren (2. Spiegelpunkt)
Dank für den Hinweis, die Stelle haeb ich nicht gefunden. :nw Die vhd-Datei liegt auf D:, ist aber von der Sicherung ausgeschlossen. Na denn, dann muss ich F: halt anders sichern, schade ...

Herzlichen Dank, Nobby! :D
Acer H340 mit 2 x WD Blue WD20EZRZ 2 TB; 1 x WDC WD20 (2TB), 1 x WD20EZRX Green 2TB
Windows Home Server Konsole: 6.0.2423.0
Windows Home Server Sichern und Wiederherstellen: 6.0.2423.0
Windows Home Server Laufwerkextender: 6.0.2423.0
Windows Home Server Remotezugriff: 6.0.3436.0
Windows Home Server Speicher-Manager: 6.0.3039.0

1 Client W7 Prof. 64, 1 Client Win 8.1Prof 64, 1 Surface Pro Win 10; Fritzbox 7390,2 x HP Procurve Swich für den Stern und auf den Stockwerken

Benutzeravatar
Nobby1805
Moderator
Beiträge: 20727
Registriert: 6. Jun 2009, 17:40
Wohnort: Essen

Re: Sicherung auf den WHS funktioniert nicht - Volumesnapshot die 1000.

Beitrag von Nobby1805 » 8. Mai 2017, 15:41

:nw Dann verstehe ich aber nicht warum es mal funktioniert hat und jetzt nicht mehr :nw

Schau doch mal ob du auf dem Client noch eine alte BackupEngine-Log findest wo es noch funktioniert hat ... würde mich sehr interessieren
WHS: Acer H340 mit 2x 1 TB (WD10EAVS), 2x 2 TB (WD20EARS), PP3+UR2
5 Clients:
1 Intel i5-4670K, ASUS H87-PRO, 16 GB, 250 GB SSD, 2x 500 GB, Win 10 Pro x64 1709
1 Lüfterlos fürs Wohnzimmer, Intel Celeron D 1900, 4 GB, 240 GB, Win 10 Pro x64 1709
1 HP G 5230, Win 10 Pro 1703
1 Sony Vaio EB 2H4E, Win7 Home Prem. x64 (bleibt auf W7 weil Sony keine W10-Grafiktreiber anbietet :cry: )
1 Samsung NP-R540-JS09DE, Win 10 Pro x64 1709


WHSListTombstones, ein Tool zur Auflistung aller Tombstones
WHSDisks, ein Tool zur Darstellung und Prüfung der DriveExtender-Konfiguration
WHSDiskNames, ein Tool zur Änderung der Plattennamen in der Konsole
WHSBackup, Infos und Tool zur Backup-DB (2011-Version (auch für WSE2012))
Bitte schreibt bei Fragen und Problemen eure Konfig in die Signatur

Antworten