Seite 1 von 1

Windows Server 2012r2 und Windows 10 1803

Verfasst: 14. Jul 2018, 18:16
von mimatthies
Hallo, seit der Neuinstallation auf Windows 10 1803 kann ich auf den PC den Connector nicht mehr installieren. Erst wird der Server gefunden und nach Eingabe von Name und Password kommt nach einiger Zeit der Computer kann nicht mit Netzwerk verbunden werden.
Der Server ist nicht verfügbar....
Sowohl über Remotedesktop und Explorer kann ich auf Server und Daten zugreifen.
Habt ihr eine Lösung?
Grüße Michael

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 14. Jul 2018, 18:53
von larry
Wenn du vor dem Update auf 1803 den Connector mit dem Registryeintrag "SkipDomainJoin" installiert hast, müsstest du dieser erst wieder setzen, bevor du den Connector wieder installierst.

Gruß
Larry

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 14. Jul 2018, 19:23
von mimatthies
Super, Danke, Eintrag ergänzt und schon geht es....

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 23. Aug 2018, 19:38
von HTPCSourcer
Hallo,

ich habe das Problem auf einer Win-Neuinstallation, die von 1709 nach 1803 gehoben wurde. Wenn ich jetzt den Connector zum Verbinden mit Server 2012E aufrufe, erhalte ich nach Eingabe von Benutzernamen und Passwort immer ein "Der Server wurde nicht gefunden".

Da noch nie eine Domänenverbindung bestanden hat, hilft mir auch der o.g. Tipp mit SkipDomainJoin nicht. Hat jemand eine Idee? Bisher konnte ich meine verschiedenen Clients auf 1709 lassen, aber langsam läuft die 365-Tage-Frist ab.


Gruß, HTPCSourcer

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 23. Aug 2018, 21:09
von larry
Das hast du glaube ich falsch verstanden.
Wenn der Client noch nie eine Domänenverbindung hatte, dann wurde die Installation mit dem SkipDomainJoin Eintrag durchgeführt. Ansonsten erfolgt automatisch eine Verbindung zur Domäne. Eine Ausnahme davon wäre, wenn du Windows 10 in der Home-Version nutzt.
Hast du testweise mal den Registryeintrag gesetzt?

Gruß
Larry

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 24. Aug 2018, 17:39
von HTPCSourcer
Also: das Problem besteht ausnahmslos bei allen PCs, die hier mit Win 10 Pro laufen.

Ich hatte gehofft, dass eine Maschine, die noch nie eine Domain gesehen hat, weniger Probleme bereitet. Es spielt in diesem Fall keine Rolle, ob der SkipDomainJoin 1 oder 0 ist. Der Connector meldet in beiden Fällen nach der User/Passwort-Eingabe ein "Server nicht verfügbar". Im ClientDeploy-Log finde ich dann die Fehlermeldung:
[2980] 180823.184833.8761: ClientSetup: MachineIdentityManager.GetMachineStatus had errors: ErrorCatalog:NetworkError ErrorCode:-1
BaseException: Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityException: MachineIdentityManager.GetMachineStatus ---> System.ServiceModel.FaultException: Der Server konnte die Anforderung aufgrund eines internen Fehlers nicht verarbeiten. Wenn Sie weitere Informationen zum Fehler erhalten möchten, aktivieren Sie entweder IncludeExceptionDetailInFaults (über das ServiceBehaviorAttribute oder das <serviceDebug>-Konfigurationsverhalten) für den Client, um die Ausnahmeinformationen zurück an den Server zu senden, oder aktivieren Sie die Ablaufverfolgung gemäß der Microsoft .NET Framework SDK-Dokumentation, und überprüfen Sie die Serverablaufverfolgungsprotokolle.

Server stack trace:
bei System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
bei System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
bei System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
bei System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
bei System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
bei System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
bei System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
bei Microsoft.WindowsServerSolutions.Devices.Identity.ICertService.GetMachineStatus(MachineStatus& status, Boolean& isAdmin, Int32& maxClientNum, Int32& currentClientNum, String userName, String password, String machineName)
bei Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityManager.GetMachineStatus(String serverName, String userName, String password, String machineName, Boolean& isAdmin)
--- Ende der internen Ausnahmestapelüberwachung ---
bei Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityManager.GetMachineStatus(String serverName, String userName, String password, String machineName, Boolean& isAdmin)
bei Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.ValidateUserTask.Run(WizData data)
[2980] 180823.184833.8761: ClientSetup: Exiting ValidateUserTask.Run

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 24. Aug 2018, 17:47
von HTPCSourcer
P.S.: Ich habe schon darübr nachgedacht, den Server neu aufzusetzen. Aber das ist auch gleichzeitig mein MediaPortal-Produktivsystem, so dass das nicht mal eben so geht. Statt des aktuell genutzten WS 2012E hätte ich dann folgende Optionen:

1. WS 2012E R2
2. WS 2016

Für den 2012E R2 1 habe ich Lizenzen, bin mir aber unsicher, ob ich eine komplette Neuinstallation brauche oder die vorhandene 2012E-Installation "einfach" auf 2012E R2 heben kann. Vielleicht kann jemand dazu ja ein paar Angaben machen.

Für WS 2016 würde ich erst einmal die kostenfreie Testversion (auf einer neuen SDB) installieren und schauen, wie es sich verhält.

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 25. Aug 2018, 10:22
von larry
Hast du auf dem Server VPN-Verbindung aktiviert?
Wenn ja, versuche es mal mit deaktiviertem VPN.

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 25. Aug 2018, 11:03
von HTPCSourcer
larry hat geschrieben:
25. Aug 2018, 10:22
Hast du auf dem Server VPN-Verbindung aktiviert?
Nein, da hatte ich schon nachgeschaut. VPN wurde niemals eingerichtet und kann daher auch nicht deaktiviert werden.

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 25. Aug 2018, 18:59
von larry
Dann tippe ich eher drauf, dass es mit Windows 10 1803 nicht zu tun hat.
Du könntest mal einen Client aus dem Dashboard löschen und dann eine Neuinstallation des Connectors auf dem Client testen.

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 25. Aug 2018, 20:18
von HTPCSourcer
Vor ca drei Wochen habe ich das in ähnlicher Form mit einem Win 10 Home-Client (mit 1709) gemacht:

Auf dem Client aus der Domäne entfernt, Connector deinstalliert. Dann Connector erneut installiert. PC konnte sich problemlos verbinden. Aber ich kann natürlich nicht sicher sein, dass die WSE 2012-Installation zu 100% intakt ist. Wobei es mit 1709 immer funktioniert, aber mit 1803 eben nicht.

Re: Conector Windows Server 2012r2 und Windows 10 1803

Verfasst: 8. Okt 2018, 16:31
von it-senior
Es funktioniert auch die folgende Vorgehensweise bei Client WIN 10 Prof.(Vers.1803) 1. IP6 ausschalten, 2.Arbeitsgruppe beitreten (Domänenname), eventuell am Server den Domänen Computer eintragen, 3. Neustart am Client, 4. Connect am Client WIN 10 ausführen.

Re: Windows Server 2012r2 und Windows 10 1803

Verfasst: 9. Okt 2018, 09:48
von Nobby1805
Hinweis: bei 1809 gibt es diverse Probleme wenn IPv6 abgeschaltet ist … z.B. funktioniert der Edge nicht mehr