Client-Probleme nach Windows 10 Fall Creators Update?

Allgemeine Themen rund um WHS2011 (vormals Codename Vail).
Antworten
testing
Foren-Mitglied
Beiträge: 62
Registriert: 10. Aug 2010, 23:08

Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von testing » 10. Dez 2017, 22:42

Hallo zusammen,

ich habe momentan mehrere Probleme mit meinem WHS 2011. Aber alles der Reihe nach:

- Serverplatte war voll. Lösung: Alle Dateien von C:\Temp gelöscht (~ 200 GB). Wahrscheinlich wieder CBS.log Dateien ...
- Laufzeitfehler bei Aufruf von SERVERNAME/Connect wie hier und hier. Lösung war von v2 auf v4 zu stellen. Ich vermute das dies durch ein Update des Servers passiert ist.
- Auf einem Client (schon verbunden mit dem Server) funktioniert die Meldungsübersicht und der Sicherungsstatus nicht mehr (Windows 10 Fall Creators Update installiert). Das Dashboard kann ich vom Client aus aber z.B. normal öffnen. Sicherungen wurden seit dem Creators Update keine mehr durchgeführt ... Zugriff über Remote Desktop funktioniert problemlos.
In der Meldungsanzeige sind keine Warnungsbenachrichtigungen verfügbar. Grund: Fehler, nicht abgeschlossene Aktion, oder ein Dienst reagiert nicht mehr. Wenden Sie sich an den Serveradministrator, wenn das Problem weiterhin besteht.
Mit dem Windows Server-Anbieterdienst für die Computersicherung kann keine Verbindung hergestellt werden.
Wenn ich die Log-Files so durchsehe, finde ich oft:
Could not connect to provider within the timeout
- (Neu-)Verbindung zum Server mittels Client Connector funktioniert nicht. Bekomme nach der Server Passworteingabe folgenden Fehler:
Der Computer kann nicht mit dem Netzwerk verbunden werden.
Der Server ist nicht verfügbar. Versuchen Sie erneut, eine Verbindung mit dem Computer herzustellen. Weitere Informationen finden Sie unter "Behandeln von Problemen beim Verbinden von Computern mit dem Server".
Nun zu meinem ursprünglichen Anliegen:

Ein Client wurde neu aufgesetzt und dieser soll wieder mit dem Server verbunden werden. Dies funktioniert wie oben beschrieben nicht. Folgende Dinge kann ich noch dazu mitteilen:
- Von diesem Client-Rechner aus war eine Heimnetzgruppe erstellt worden. Den "alten" Client-Rechner gibt es ja nicht mehr. Momentan bin ich überall aus der Heimnetzgruppe ausgetreten.
- Client-Rechner hat nun einen neuen Rechnernamen.
- Dieser Client hat nun auch Windows 10 Fall Creators Update drauf.

Entweder funktionieren auf einmal mehrere Dinge nicht mehr oder es liegt an den Updates (Server sowie Clients). Die größte Vermutung ist eben das neue Windows 10 Update. Habt ihr auch ähnliche Erfahrungen gemacht?

Wenn ich nach der FAQ gehe sind mir einige Dinge nicht so klar:
- Wie starte ich IE in 32 Bit?
- Wie soll der Registry-Eintrag erstellt werden (Schlüssel, ...)? Wo? Am Client oder Server?
- .Net 4.0 neu installieren. Wo? Am Client oder Server oder beides?
- Wie IPv6 deaktivieren? Häkchen beim Adapter einfach rausnehmen?

Firewall (Windows Defender) und UAC schließe ich mal aus, denn er fragt ja nach ob ich mit Admin-Rechten die Connector-Software ausführen will. Bisher hat noch nichts zum Erfolg geführt. Sind evtl. ein paar Dienste nicht gestartet (Anmeldedienst, Anwendungshost-Hilfsdienst, Integritätsdienst von Windows Server, ...)? Anmeldedienst z.B. läuft nicht. Wenn ich ihn starte kommt
Dienst "Anmeldedienst" wurde auf "Lokaler Computer" gestartet und dann angehalten. Einige Dienste werden automatisch angehalten, wenn sie nicht von anderen Diensten oder Programmen verwendet werden.
Die Ereignisanzeige meint dazu
Dieser Computer ist als Mitglied einer Arbeitsgruppe konfiguriert, nicht als Mitglied einer Domäne. Der Anmeldedienst braucht bei dieser Konfiguration nicht gestartet zu sein.
Hab jetzt noch einen Forum-Eintrag über ein Windows 10 Update gefunden, wofür man einen Registry-Eintrag hinzufügt. Das habe ich bis jetzt noch nie machen müssen. Soll ich?

Habt ihr ein paar Tips für mich?

Benutzeravatar
larry
Moderator
Beiträge: 9887
Registriert: 22. Dez 2007, 16:13

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von larry » 13. Dez 2017, 19:46

Hast du denn noch einen Client bei dem alles funktioniert? Für mich hört sich das eher nach einem WHS 2011 Problem an. Die FAQ Einträge Clienstinstallation würde ich daher erst einmal außer acht lassen.
Schau doch zuerst einmal, ob alle Dienste gestartet sind, welche als Starttyp automatisch haben.

Deine zuletzt genannten Registry-Eintrag Links beziehen sich auf den Server Essential 2012 und 2016. Hat beim WHS 2011 keine Auswirkung.

Gruß
Larry

testing
Foren-Mitglied
Beiträge: 62
Registriert: 10. Aug 2010, 23:08

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von testing » 14. Dez 2017, 22:01

Hi Larry,

danke für deine Antwort! Ich hab nur die zwei Clients ... Beim einen habe ich jetzt den Dienst "Windows Server-Anbieterdienst für die Clientcomputersicherung" gestartet und nun geht hier der Backup-Prozess momentan wieder. Die Meldungsanzeige geht aber immer noch nicht und das Launchpad hat noch immer ein rotes Icon.

Von den Diensten her bin ich mal diesen Guide durchgegangen, aber die zwei genannten Dienste am Server waren schon gestartet.

Dienste mit Starttyp automatisch, aber nicht gestartet:
- OcButtonService
- Windows Server-Initialisierungsdienst
- Microsoft .NET Framework NGEN v4.0.30319_X64
- Microsoft .NET Framework NGEN v4.0.30319_X86
- Software Protection

Also hier scheint der Initialisierungsdienst am ehesten interessant zu sein, oder was meinst du?

Grundsätzlich habe ich auch schon die Vermutung gehabt, dass am Server z.B. die Firewall gewisse Dinge blockiert, ich bin aber leider noch nicht weiter gekommen das zu testen. Jedenfalls halte ich dich auf dem Laufenden, wenn ich mehr weiß. Momentan lass ich mals das Backup durchlaufen und schau ob er auch bis 100% kommt.

Gruß
testing

Benutzeravatar
larry
Moderator
Beiträge: 9887
Registriert: 22. Dez 2007, 16:13

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von larry » 15. Dez 2017, 18:49

Den ersten Dienst kenne ich nicht. Gehört auf alle Fälle nicht zu den Microsoft Server-Diensten.
Die 4 weiteren sind ok, wenn diese nicht laufen.

Gruß
Larry

testing
Foren-Mitglied
Beiträge: 62
Registriert: 10. Aug 2010, 23:08

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von testing » 16. Dez 2017, 22:18

Ich habe jetzt mal die Firewall am Server ausgeschaltet, aber das hat nichts gebracht. Dann habe ich auf einen anderen Windows-Rechner das Connect Tool ausgeführt, als auch in einer VM mit einer älteren Windows 10 Version, als auch an dem einzigen "verbundenen" Client und hier bekomme ich folgende Fehlermeldung:
Der Computer kann nicht mit dem Server verbunden werden, weil eine andere Softwareinstallation ausgeführt wird oder ein Neustart des Computers aussteht. Schließen Sie die Installation ab, oder starten Sie den Computer neu, und verbinden Sie den Computer enreut mit dem Server.
Es sind aber nur optionale Updates vorhanden und es steht kein Neustart aus, auch keine Softwareinstallation. Beim anderen Win10 Rechner den ich neu aufgesetzt habe, kommt immer noch die alte Fehlermeldung ("Server ist nicht verfügbar").

Dann habe ich mir noch mal die Log-Files unter C:\ProgramData\Microsoft\Windows Server\Logs\ angesehen. Interessanterweise gibt's die auch bei nicht verbundene Clients. Da fand ich das im ClientDeploy.log:
[7600] 171209.011707.3361: ClientSetup: MachineIdentityManager.GetMachineStatus had errors: ErrorCatalog:NetworkError ErrorCode:-1
BaseException: Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityException: MachineIdentityManager.GetMachineStatus ---> System.ServiceModel.ServerTooBusyException: Der HTTP-Dienst auf https://example:65500/CertWebservice.svc ist nicht verfügbar. Möglicherweise ist der Dienst ausgelastet, oder es wurde kein Endpunkt gefunden, der an der angegebenen Adresse lauscht. Stellen Sie sicher, dass die richtige Adresse angegeben ist, und versuchen Sie später erneut, auf den Dienst zuzugreifen. ---> System.Net.WebException: Der Remoteserver hat einen Fehler zurückgegeben: (503) Server nicht verfügbar.
Dann bin ich noch mal in den IIS-Manager gegangen und hab den "CertWebservice" gesucht.Dort war das .Net Framework 2.0 eingestellt. Dann habe ich mich an den Anfang des Threads zurück erinnert und auf v.4 gestellt. Nun hat der Client Connector am neu augesetzten Windows funktioniert. Ich weiß jetzt noch nicht ob alle Fehler weg sind, aber das ist ja mal ein großer Schritt weiter. Im Anhang ein Bild von meiner aktuelle Konfiguration. Sieht das bei dir auch so aus?

Anwendungspools.png
IIS-Manager
Anwendungspools.png (29.82 KiB) 2267 mal betrachtet

Benutzeravatar
larry
Moderator
Beiträge: 9887
Registriert: 22. Dez 2007, 16:13

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von larry » 17. Dez 2017, 15:59

zu meiner Konfig gibt es noch ein paar Abweichung:
Anwendungspools.png
Anwendungspools.png (22.38 KiB) 2236 mal betrachtet

testing
Foren-Mitglied
Beiträge: 62
Registriert: 10. Aug 2010, 23:08

Re: Client-Probleme nach Windows 10 Fall Creators Update?

Beitrag von testing » 17. Dez 2017, 22:34

Vielen Dank larry, ich hab die Konfiguration so übernommen!

Antworten