hMailServer auf Netzlaufwerk installieren

E-Mail auf dem WHS und weitere Themen
Antworten
Holger Hessling
Foren-Mitglied
Beiträge: 57
Registriert: 24. Feb 2012, 20:19

hMailServer auf Netzlaufwerk installieren

Beitrag von Holger Hessling » 5. Dez 2012, 20:46

Hallo,

bei mir läuft seit einigen Jahren der hMailServer völlig ohne Probleme auf WHS V1 und ich bin sehr zufrieden mit diesem Programm. Bei der Installation damals habe ich den Server, wie vom Install vorgeschlagen, auf c:\Programme\hMailServer installiert. Nachdem die C-Partition nur 20GB groß ist, bekam ich im Laufe der Zeit Platzprobleme.

Nun ist der Leidensdruck groß genug, sodaß ich daran gegangen bin, alle Mails zu sichern, den Server zu deinstallieren und auf einem größeren Laufwerk neu zu installieren. Die Idee war, auf dem WHS einen freigegebenen Ordner zu erstellen und diesen im WHS selbst wieder als M: anzubinden. Dort installierte ich also den hMailServer. Das ging auch völlig ohne Probleme.

Beim Starten des "hMailServer Administrator" konnte ich mich aber nicht anmelden. Da kam eine längliche Fehlermeldung die in etwa so lautete:

"Die COM-Klassenfactory für die Remotekomponente mit der CLSID { ... } konnte aufgrund des folgenden Fehlers nicht von Computer localhost abgerufen werden: 80070003"

Wenn ich den hMailServer auf c: installiere, geht's. Ich nehme mal an, der Server hat ein Problem damit, auf einem Netzlaufwerk installiert zu werden.

Hat einer von Euch eine Idee, wie ich es trotzdem schaffen kann? Vielleicht kann man ja auch die C-Partition des WHS V1 größer machen??

Danke für Eure Hinweise

Holger

Holger Hessling
Foren-Mitglied
Beiträge: 57
Registriert: 24. Feb 2012, 20:19

Re: hMailServer auf Netzlaufwerk installieren

Beitrag von Holger Hessling » 5. Dez 2012, 20:59

okay, erledigt :-D Es muß \\Server\Freigabe\Programme\hMailServer heißen.

Benutzeravatar
jsysde
Foren-Mitglied
Beiträge: 391
Registriert: 5. Sep 2011, 09:57
Wohnort: Bad Offenbach am Meer
Kontaktdaten:

Re: hMailServer auf Netzlaufwerk installieren

Beitrag von jsysde » 8. Dez 2012, 10:13

Die Erklärung dafür ist banal: hMailServer läuft als Dienst und daher nicht in deinem User-Kontext. Das gemappte Netzlaufwerk steht aber nur in deinem User-Kontext zur Verfügung, daher "sieht" der Dienst das Laufwerk schlicht nicht und meldet einen Fehler. Zugriff auf UNC-Pfade sind hingegen kein Problem, wie du ja bemerkt hast.

Cheers,
jsysde
select * from users where iq > 60
0 rows returned.

Holger Hessling
Foren-Mitglied
Beiträge: 57
Registriert: 24. Feb 2012, 20:19

Re: AW: hMailServer auf Netzlaufwerk installieren

Beitrag von Holger Hessling » 14. Dez 2012, 14:08

Danke für Deine Erklärung! Das ist absolut nachvollziehbar :grin:

Jedoch habe ich seit dem Umzug von C: auf das Netzwerk immer ein Problem mit der Datenintegrität auf dem Ordner. Es heißt, dass die Datei hMailServer.sdf offen wäre. Hm, der Mailserver funktioniert aber einwandfrei

Gruß Holger

Gesendet von meinem GT-N7000 mit Tapatalk 2

Holger Hessling
Foren-Mitglied
Beiträge: 57
Registriert: 24. Feb 2012, 20:19

Re: hMailServer auf Netzlaufwerk installieren

Beitrag von Holger Hessling » 17. Dez 2012, 07:55

Hallo jsysde,

mittlerweile residiert der Mailserver in seiner aktuellen Version auf dem WHS2011. Bei der Installation habe ich wie vorher einen UNC Pfad angegeben, dieser ist aber diesmal in einen Pfad mit Laufwerksbuchstaben geändert worden. Offenbar macht der Server 2008 hier etwas Grundlegendes anders als der Server 2003. Kannst Du mir das bitte kurz erläutern?

Danke :)

Gruß
Holger

Antworten