Itunes auf dem WHS (nicht Itunes Server oder firefly)

Windows Home Server in Verbindung mit Multimedia
ageage
Foren-Einsteiger
Beiträge: 37
Registriert: 17. Jun 2009, 14:53

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von ageage » 17. Jun 2011, 23:26

hallo vanish,

erstmal lieben dank fuer dein engagement! findet man nicht oft!

bei mir ist alles os wie du es in deinem letzten post beschrieben hast....ich dreh mich im kreis....

(allerdings muss ich anmerken das bei mir noch irgendwianders ein mega wurm schlummert....RDC und konsole sind alle 2 Minuten schlichtweg eingefroren und fuer ca 5-10 min nicht nutzbar (cpulast 4%, netzlast 1%). reboot hilft fuer 10 min ....dann geht es wieder los....bedeutet also das ich hier ewig warte um installationen oder aehnliches vorzunehmen.....EGAL! kommt spaeter))

ich probiers jetzt mal mir dem VAC (wusste nicht das es sich dabei um Software handelt)

ein cheers fuer vanish!
ageage

sann
Foren-Einsteiger
Beiträge: 5
Registriert: 17. Jun 2011, 09:48

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von sann » 18. Jun 2011, 00:40

Ich habe die Sache jetzt ziemlich eingrenzen können.

Folgende Situation: Ich logge mich per UltraVNC in den WHS ein und öffne JTunes.

1. Wenn ich den jtunes-service stoppe und itunes öffne --> dann kann ich alles super mit der RemoteApp übers iPhone fernsteuern und die Musikwiedergabe über die USB-Soundkarte funktioniert.

2. Wenn ich aber itunes schließe und den jtunes-service starte (da wollen wir ja hin .-)) --> dann kann ich mich per RemoteApp zwar in die Mediathek einklinken und die Titel auswählen - sobald ich einen Titel abspielen möchte, kommt aber das Fehlerpopup auf dem iPhone "Ein unbekannter Fehler... Bitte überprüfen Sie die Mediathek".

Zwischen 1. und 2. kann ich ohne Reboot des Servers hin und her wechseln.

Also lautet die Frage: Was macht der jtunes-service nicht, was aber geschieht wenn itunes als Anwendung gestartet wird? Es muss ja ausschließlich mit der Musikwiedergabe zu tun haben. Die Mediathek samt Titelauswahl finde ich ja in beiden Fällen.

VG und gute n8

PS: Was ist VAC? Wird sich das Problem in Luft auflösen, wenn man die Musikausgabe nicht über die USB-Soundkarte macht, sondern über ein AppleTV?

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 18. Jun 2011, 08:48

Hallo sann,

Vac ist eine Software soundkarte (Virtual Audio Cable), das wird das Problem nicht lösen. Auch appletv oä glaube ich wird nicht helfen. Was du noch testen kannst ist statt dem jtunes das iTunes per any Service intaller als eigenen dienst zu definieren.
Wenn dein iTunes problemlos startet und keine Fehlermeldung beim Start gibt sondern auf den Clients die Freigabe erscheint dann ist die Konfiguration quasi schon fertig. Beim Dienst muss irgendwo der Wurm stecken. Hast du mal in der Ereignisanzeige nachgesehen ob das was auffälliges passiert?
Ansonsten vielleicht wirklich mal den anyserviceinstaller testen. Anleitung solltest du hier im Forum finden.

@ageage,
Wie ich oben geschriebenh habe, iTunes muss ohne Fehlermeldung starten. Sonst kann es nicht funktionieren
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

sloomf
Foren-Einsteiger
Beiträge: 13
Registriert: 29. Mai 2009, 09:11

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von sloomf » 18. Jun 2011, 10:49

Hallo zusammen,

Ich habe ein Problem mit dem Bonjour Dienst bzw. der Privatfreigabe.

Wenn ich den Homeserver neu starte und iTunes normal starte kann ich im AppleTV die Freigabe sehen und "normal" darauf zugreifen.
Sobald der Homeserver in den Standby geht und dann wieder aktiviert wird ist die Freigabe weg.

Ich habe Bonjour schon im LightsOut eingetragen und laut Diensteliste wird ist er nach dem Standby auch gestartet.
Daraufhin habe ich nach einem Neustart und funktionierender Freigabe den Bonjour Dienst testhalber in der Diensteliste gestoppt und neu gestartet (Also ohne Standby) und schon war die Privatfreigabe wieder weg.

Ich blick es nicht. Laut Diensteliste läuft Bonjour aber zugreifen kann ich trotzdem nicht - gibt es noch was anderes zu beachten?

Danke für eure Hilfe
Stephan

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 18. Jun 2011, 10:57

Hi sloomf,

Du musst Bonjour und den iTunes Dienst bei lightsout eintragen. Dann sollte es gehen.

Vg,
Vanish
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

sloomf
Foren-Einsteiger
Beiträge: 13
Registriert: 29. Mai 2009, 09:11

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von sloomf » 18. Jun 2011, 13:01

Hallo Vanish,

Wie geschrieben ist Bonjour bereits im lightsout eingetragen.
Itunes läuft aktuell nicht als service sondern ganz "normal", daher kann ich da auch nix eintragen - oder gibt es noch einen anderen Dienst?

Wie auch geschrieben, das Problem scheint mir auch zu sein, dass selbst ohne LightsOut - nur durch das Stoppen und Neustarten des Bonjour-Dienstes die Privatfreigabe verschwindet.

Kann jemand das Problem nachvollziehen?
Stephan

ageage
Foren-Einsteiger
Beiträge: 37
Registriert: 17. Jun 2009, 14:53

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von ageage » 18. Jun 2011, 14:43

...wenn ich es richtig verstanden habe musst du bonjour und itunes auch noch unter dep eintragen. sonst geben die dienste die freigaben nach standby nicht weiter

ageage

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 18. Jun 2011, 16:35

sloomf hat geschrieben:Hallo Vanish,

Wie geschrieben ist Bonjour bereits im lightsout eingetragen.
Itunes läuft aktuell nicht als service sondern ganz "normal", daher kann ich da auch nix eintragen - oder gibt es noch einen anderen Dienst?

Wie auch geschrieben, das Problem scheint mir auch zu sein, dass selbst ohne LightsOut - nur durch das Stoppen und Neustarten des Bonjour-Dienstes die Privatfreigabe verschwindet.

Kann jemand das Problem nachvollziehen?
Stephan
Wenn itunes nicht als dienst läuft, dann muß bonjour ggf. auch nicht neu gestartet werden?
Bei mir ist es so dass nach dem aufwachen beides neu gestartet werdem muß itunes, welches bei mir als dienst läuft und bonjour. Beides mache ich über lightsout...

Vg,
vanish
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

sann
Foren-Einsteiger
Beiträge: 5
Registriert: 17. Jun 2011, 09:48

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von sann » 19. Jun 2011, 21:57

Hallo zusammen, ich habe jetzt nochmal ein paar Sachen getestet.
Wie schon geschrieben, läuft das iTunes als Dienst nicht ordnungsgemäß. Per RemoteApp kann ich mich mit der Mediathek verbinden und Titel durchsuchen. Beim Abspielen der Titel bekomme ich aber die Fehlermeldung in der App "Unbekannter Fehler usw..."

Ich habe jetzt sowohl JTunes als auch AnyServiceInstaller getestet. Beide bringen o.g. Ergebnis.
Auch habe ich anstatt der USB-Soundkarte mal das VirtualAudioCable in Kombination mit AppleTV2 getestet. Beides bringt o.g. Ergebnis.

Wie schon gesagt, wenn ich anstatt des Dienstes das iTunes als Anwendung auf dem Server per RemoteDesktop starte funktioniert alles wunderbar.

Es muss also in der Natur des DIENSTES liegen. An welchen Stellen kann man da noch drehen? Liegt's am Ende am Account

@vanish: Du hattest geschrieben, dass auch Deine library.xml auf dem Netzlaufwerk /music liegt. Wie hast Du das gemacht? Liegt die nicht standardmäßig im Benutzername/eigene dateien/usw. Kann das ein wichtiger Punkt in der ganzen Geschichte sein?

Ich vermute, dass dem itunes als Dienst irgendwelche Rechte fehlen um korrekt die Audioausgabe zu bewerkstelligen. Entscheidend scheint der Account zu sein, unter dem itunes installiert und als Dienst gestartet wird. Für alles habe ich den Administrator-Account verwendet. Trotzdem geht's nicht.

PS nebenbei:
- Auch wenn ich mich per RDV (sowohl Windows als auch Mac) und der Einstellung "Audiowiedergabe auf dem Server" verbinde, habe ich in den Audioeinstellungen auf dem Server nur dieses RDP Audio zur Auswahl. Nur wenn ich UltraVNC verwende zeigt mir der WHS die USB-Soundkarte bzw. das VAC standardmäßig an.
- Wenn ich mich per UltraVNC in den WHS einwähle und im itunes einstellungen ändere, dann speichert er die nicht.

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 20. Jun 2011, 00:02

sann hat geschrieben:Hallo zusammen, ich habe jetzt nochmal ein paar Sachen getestet.
Wie schon geschrieben, läuft das iTunes als Dienst nicht ordnungsgemäß. Per RemoteApp kann ich mich mit der Mediathek verbinden und Titel durchsuchen. Beim Abspielen der Titel bekomme ich aber die Fehlermeldung in der App "Unbekannter Fehler usw..."

Ich habe jetzt sowohl JTunes als auch AnyServiceInstaller getestet. Beide bringen o.g. Ergebnis.
Auch habe ich anstatt der USB-Soundkarte mal das VirtualAudioCable in Kombination mit AppleTV2 getestet. Beides bringt o.g. Ergebnis.

Wie schon gesagt, wenn ich anstatt des Dienstes das iTunes als Anwendung auf dem Server per RemoteDesktop starte funktioniert alles wunderbar.

Es muss also in der Natur des DIENSTES liegen. An welchen Stellen kann man da noch drehen? Liegt's am Ende am Account

@vanish: Du hattest geschrieben, dass auch Deine library.xml auf dem Netzlaufwerk /music liegt. Wie hast Du das gemacht? Liegt die nicht standardmäßig im Benutzername/eigene dateien/usw. Kann das ein wichtiger Punkt in der ganzen Geschichte sein?

Ich vermute, dass dem itunes als Dienst irgendwelche Rechte fehlen um korrekt die Audioausgabe zu bewerkstelligen. Entscheidend scheint der Account zu sein, unter dem itunes installiert und als Dienst gestartet wird. Für alles habe ich den Administrator-Account verwendet. Trotzdem geht's nicht.

PS nebenbei:
- Auch wenn ich mich per RDV (sowohl Windows als auch Mac) und der Einstellung "Audiowiedergabe auf dem Server" verbinde, habe ich in den Audioeinstellungen auf dem Server nur dieses RDP Audio zur Auswahl. Nur wenn ich UltraVNC verwende zeigt mir der WHS die USB-Soundkarte bzw. das VAC standardmäßig an.
- Wenn ich mich per UltraVNC in den WHS einwähle und im itunes einstellungen ändere, dann speichert er die nicht.
Du kannst in iTunes unter den Einstellungen festlegen wie und wo es die Musik ablegt. Außerdem kannst du deine mediathek speichern und zwar dahin wo du möchtest.
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

ageage
Foren-Einsteiger
Beiträge: 37
Registriert: 17. Jun 2009, 14:53

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von ageage » 20. Jun 2011, 12:12

hgallo zusammen,

anbei mein aktueller Status:

unter der Win RDP habe ich es nicht geschafft iTunes dazu zu bewegen sich ohne Fehlermeldung zu starten. :twisted:

nicht mit VAC (keine Fehlermeldungen oder ähnliches im Gerätemanage)
als auch mit delock 7.1 USB Stick (c-media chipset). der usb Stick wurde nur als USB audiogerät angezeigt (keine Fehler). Allerdings wurde er nicht unter den Audiogeräten korrekt aufgeführt. Dort stand immer nur ein Standard Microsoft Treibe - und den scheint iTunes verweigert zu haben.

Jetzt habe ich mit mit TeamViewer auf den WHS eingeloggt und nochmal die Treiber aktualisiert.
Unter Gerätemanager keine Änderung.
ABER!!!!
unter Audiogeräten wird jetzt korrekt die Karte erkannt.
ITunes gestartet - keine Fehler :P :P :P .

Titel gestartet - und iTunes spielt - ich konnte den Ton logischerweise nicht hören. Also iTunes beendet und mit Jtunes den Dienst neu installiert (vorher Firefly in den Diensten manuell deaktiviert)

So!

Ich hoffe inständig das iTunes seine Einstellungen "behält" und Jtunes das ganze "übernommen" hat.
Kann es kaum erwarten wieder nach Hause zu kommen - werde dann berichten


ageage

sann
Foren-Einsteiger
Beiträge: 5
Registriert: 17. Jun 2011, 09:48

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von sann » 20. Jun 2011, 13:09

vanish0845 hat geschrieben:
sann hat geschrieben:Hallo zusammen, ich habe jetzt nochmal ein paar Sachen getestet.
Wie schon geschrieben, läuft das iTunes als Dienst nicht ordnungsgemäß. Per RemoteApp kann ich mich mit der Mediathek verbinden und Titel durchsuchen. Beim Abspielen der Titel bekomme ich aber die Fehlermeldung in der App "Unbekannter Fehler usw..."

Ich habe jetzt sowohl JTunes als auch AnyServiceInstaller getestet. Beide bringen o.g. Ergebnis.
Auch habe ich anstatt der USB-Soundkarte mal das VirtualAudioCable in Kombination mit AppleTV2 getestet. Beides bringt o.g. Ergebnis.

Wie schon gesagt, wenn ich anstatt des Dienstes das iTunes als Anwendung auf dem Server per RemoteDesktop starte funktioniert alles wunderbar.

Es muss also in der Natur des DIENSTES liegen. An welchen Stellen kann man da noch drehen? Liegt's am Ende am Account

@vanish: Du hattest geschrieben, dass auch Deine library.xml auf dem Netzlaufwerk /music liegt. Wie hast Du das gemacht? Liegt die nicht standardmäßig im Benutzername/eigene dateien/usw. Kann das ein wichtiger Punkt in der ganzen Geschichte sein?

Ich vermute, dass dem itunes als Dienst irgendwelche Rechte fehlen um korrekt die Audioausgabe zu bewerkstelligen. Entscheidend scheint der Account zu sein, unter dem itunes installiert und als Dienst gestartet wird. Für alles habe ich den Administrator-Account verwendet. Trotzdem geht's nicht.

PS nebenbei:
- Auch wenn ich mich per RDV (sowohl Windows als auch Mac) und der Einstellung "Audiowiedergabe auf dem Server" verbinde, habe ich in den Audioeinstellungen auf dem Server nur dieses RDP Audio zur Auswahl. Nur wenn ich UltraVNC verwende zeigt mir der WHS die USB-Soundkarte bzw. das VAC standardmäßig an.
- Wenn ich mich per UltraVNC in den WHS einwähle und im itunes einstellungen ändere, dann speichert er die nicht.
Du kannst in iTunes unter den Einstellungen festlegen wie und wo es die Musik ablegt. Außerdem kannst du deine mediathek speichern und zwar dahin wo du möchtest.

Den Ort der Mediathek kann man selbst definieren - klar. Aber die xml lässt sich glaube ich ausschließlich im Standardverzeichnis unterbringen.
Zuletzt geändert von sann am 20. Jun 2011, 14:14, insgesamt 1-mal geändert.

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 20. Jun 2011, 13:57

@ ageage:
Ich drücke die Daumen!

@ sann:
Nö, der Speicherort ist auch frei. Wenn mich nicht alles täuscht, dann kannst du die xml Datei auch irgendwo hinkopieren und mit itunes schlicht öffnen.

Vg,
vanish
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

ageage
Foren-Einsteiger
Beiträge: 37
Registriert: 17. Jun 2009, 14:53

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von ageage » 21. Jun 2011, 12:12

YES!!!! :D :D :D

das ipad sieht schonmal die Mediathek und stellt alles inkl. covern, etc. perfekt dar!

Ich habe der Versuchung widerstanden sofort den PLAY Knopf zu drücken - ich moechte nicht das iTunes wieder irgendwelche Einstellungen die noch nicht funktionieren verinnerlicht - wenn ich dann Pech habe, habe ich das gleiche Problem wie sann.

Ich habe mir heute einen Ethernet adapter von Netgear besorgt und werde erstmal meinen AV Reciever (Yamaha RXV3900) mit dem Wlan verbinden
Ich muss allerdings gestehen das ich noch keine Ahnung habe wie ich iTunes dazu bringe dann auf dem AV Reciever "abzuspielen"

Weiss das jemand von Euch? - Irgendwer hier hat das schon gemacht aber ich finde es nicht mehr wieder.

ageage

vanish0845
Foren-Mitglied
Beiträge: 139
Registriert: 30. Nov 2009, 12:51

Re: Itunes auf dem WHS (nicht Itunes Server oder firefly)

Beitrag von vanish0845 » 21. Jun 2011, 14:45

Hallo ageagae,

Glückwunsch!
Wenn itunes ohne Fehler startet und due die Mediathek aus der ferne siehste sollte eigentlich alles passen.
(Bei mir läuft das seit bestimmt einem halben Jahr mehr oder weniger ohne Schwierigkeiten!).

Um den Sound auf den av Receiver zu bekommen sehe ich (mindestens) 2 Möglichkeiten.
Entweder von deiner Soundkarte per Kabel.
Oder (so habe ichs) gestreamt an ein AppleTV(2), welches am AV Receiver hängt. (Gehen würde auch Airport Express)

Vg,
vanish
Whs2011 auf selbstgebautem Server: Celeron G530 boxed Lüfter/Intel DB65AL B3/Intel Gigabit Desktop LAN/Enermax ErPro80+ 350W/8Gb DDR3 RAM

Antworten