Mein Spezial - NAS-Server Eigenbau - NX-05

Hier darf jeder seinen Home Server vorstellen. Bitte jeder nur einen Thread. Fragen zu den Geräten oder der Software bitte nicht in diesem Forum.
Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 6. Sep 2010, 20:19

Hallo miteinander,
Servus liebe Home-Server User! :)

Zu allererst möchte ich mich vorstellen. Ich heisse Stefan, komme aus dem Raum Niederbayern und als Hobby Fotografiere ich gerne und viel und alles mögliche.

Im folgenden möchte ich vor einen wirklich laaaangen Roman warnen, da ich in wenigen Sätzen mein Vorhaben leider nicht erklären kann.
Dafür bitte ich zu entschuldigen.
Ungeduldige können in etwa der zweiten Hälfte erfahren, wie das fertige System aussieht.

Dies ist und war mein erster NAS-Server, den ich bisher aufgebaut habe.

Natürlich gehören Fotos gesichert. Es wäre doch schade, wenn sie wegen Unachtsamkeit des Backups verlorengingen.
In den letzten 5 Jahren haben sich bereits knappe 70.000 Fotos die ebenso knapp 150Gbyte belegen.
Natürlich muss so etwas gesichert werden.
Dazu verteilte ich den Foto-Ordner auf 3 Festplatten im heimischen PC.
Natürlich war es mühsam, den Kopiervorgang 3 x zu starten. Und ich wusste, dass auch dann die Daten nicht sicher waren, auch wenn sie auf 3 Festplatten verteilt waren, solange sich die Daten im selben Raum befänden.

Ende letzten Jahres hatte ich also die Idee einen NAS-Server anzuschaffen.
Also habe ich lange und intensiv nach Fertiglösungen Ausschau gehalten, wurde jedoch wegen zu geringer Flexibilität einfach nicht fündig.
Auch waren meine Ansprüche in Sachen Robustheit etwas höher, da es mir nicht möglich war, den Server in meinem Haus in ein Zimmer zu stellen, da wie es oft so ist, der Platz einfach begrenzt ist.

Deswegen beschloss ich sehr früh, den Server auf den Dachboden zu verweisen, da bereits sämtliche Router dort untergebracht sind.

Danach informierte ich mich lange und intensiv, wie man den Eigenbau eines NAS-Servers am besten bewerkstelligt.

Zu allererst musste die Hardwarefrage geklärt werden, da ich auch sehr großen Wert auf Sparsamkeit in Sachen Stromverbrauch wert legte.
Zu allererst versuchte ich es mit einem Servermotherboard mit AMD8111 Chipsatz und 2 250ern Opterons.
Nachdem ich das nackte Motherboard mit RAM-Bestückung angeworfen hatte, wurde in gefühlten 0,5 Sekunden das Thema Serverboard abgehakt, da bereits im Bios eine Leistungsaufnahme von sage und schreibe 118Watt auf dem Display des Messgerätes angezeigt wurden.

Tja, was nun??

Nachdem durch weiteres Lesen klar wurde dass zu Datensicherungszwecken nicht wirklich hohe CPU-Leistung gefragt ist, erinnerte ich mich an die AMD Geode NX Serie welche auf dem Thouroughbred A - Kern des AthlonXP basierte.
Ich entschied mich nun für einen NX 1500+ welcher mit 1GHz getaktet ist und laut AMD es auf geradeeinmal 9 Watt TDP bringt.
Als Motherboard nahm ich das einzige was die CPU noch am meisten unterstützte, und zwar ein ASRock K7S41GX mit SIS Onboardgrafik.

Als RAM kamen 2 512MB Module DDR400 zum Einsatz und als erstes Testbetriebssystem wählte ich Windows2000, welches ich in Ebay zu einem günstigen Preis erwarb.

Da von vorneherein geplant war ein RAID1 aufzubauen, kaufte ich einen DeLock RaidController SATA mit Sil-Image 3114 Chipsatz.
Ein großer Fehler, wie sich später herausstellen sollte. Dazu aber im späteren Text mehr.

Als die Testplattform aufgebaut und Win2k installiert war ging es gleich mal an die Stabilitätstests. Memtest sowie Prime95 kamen zum Einsatz.
12 Stunden Memtest überstand das System und der RAM fehlerfrei. Ein erster Erfolg!
Bei Prime95 stellte sich jedoch eine Instabilität nach ca. zwei Stunden Testen heraus. P95 brach mit einem Hardware-Failure ab.
Ratlosigkeit machte sich breit, da sämtliche Spannungen innerhalb der Sollwerte lagen und das System in keinster Weise übertaktet war, was ich auch nicht im geringsten vor hatte.

Der AMD Geode NX 1500+ verlangte nach einer Spannung von 1Volt (ich glaube es müssten 1V gewesen sein was ich noch im Kopf habe, kann sein dass ich mich irre, weils schon recht lange her ist). Ich hob dazu die Spannung trotzdem um +6% an.
Und siehe da , der Primetest überstand zwei Stunden.... bis zur fünften Stunde.
Jetzt war ich richtig verwirrt. Die Spannung weiter anzuheben und den Stromverbrauch zu erhöhen, sowie die Lebensdauer möglicherweise zu reduzieren war keine wirkliche Lösung, da ich ein annähernd 100%ig stabiles System wollte.

Ich kam zu dem Entschluss, dass es nicht effektiv wäre, Hardware zu vermischen die nicht wirklich zueinder passt.

Hier gehts weiter für die Überflieger :D

Also entschloss ich mich aus komplett neuer Hardware ein System aufzubauen.
Bis zu diesem Entschluss vergingen ca. 3 Monate, da ich nicht ständig Zeit hatte mich um den Server zu kümmern. Tjo, da wäre mehr Freizeit schon schön :D

Im April hatte ich dann die meiste Hardware ausgesucht.
Nach viel Zeit des informierens kam ich auf den AMD 2650e Prozessor, CPU-Z gibt in neueren Versionen auch AMD Neo MV-26 aus. Er ist im Grunde ein AM2 Athlon64 mit reduzierter Spannung und Takt.
Er taktet mit 1,6GHz, hat einen L2 Cache von 512 kbyte, was völlig ausreichend ist und hat laut AMD eine TDP von 15W. Der Kern ist ein "Lima".
Angemessen wie ich finde im Verlgleich zum wesentlich langsameren Geode.

Als Motherboard wählte ich das ASUS M4N78-AM mit GeForce 8200 Chipsatz. Eigentlich heisst ja die im Chipsatz verbaute Grafikkarte so, aber anscheinend nennt nVidia den Chipsatz wie den Grafikchip.

Die CPU besorgte ich mir Nagelneu aus den USA, da in Deutschland kein einziger Händler existierte, welcher den 2650e vertreibt.

Nur zur Info: Es gibt noch einen 3250e mit 22Watt Verbrauch. Ein DualCore mit 2 x 1,5GHz. Die neuere Athlon X2-U Serie hat diesen wohl abgelöst.

Als Gehäuse kam nur ein 19" Servergehäuse in Frage, da man dort wirklich schön an alles rankommt. :)
So fiel die Wahl auf ein 4HE Gehäuse von Fantec, welches ich gebraucht und in leicht staubigem Zustand bekam.
Dieses wurde sogleich richtig aufgemöbelt, gereinigt und ausgestaubt. Nach der Kur glänzte es wieder wie neu. :)

Die Hardware wurde dann sogleich verbaut.
Zu diesem Zeitpunkt hatte ich die Wahl schon für WHS gefällt.

Als Datenträger und Aufbau wählte ich 3 x 2 TByte Western Digital Green WD20EADS.
2 Platten sollten im Raid 1 Verbund arbeiten, das dritte Laufwerk sollte softwaremäßig als zusätzlicher Datenspeicher in WHS integriert werden.
Somit konnte ich die Sicherungsplatten in meinem Hauptrechner von 3 auf 1 reduzieren. Eine einzelne Kopie, mit der ich sorgenfrei arbeiten kann.

Ach ja, der RAM: Ich wählte 2 x 1 Gbyte von Kingston mit ECC Unterstützung.
Der Memtest sowie Prime95 liefen endlich durch! Und zwar so lange ich wollte :)
Juhuuuu, ein stabiles System!! :)

Endlich war ein großer Abschnitt gemeistert!
Als nächstes folgte der Raid-Test.
Dabei installierte ich WHS auf den Platten, und entfernte eine der beiden Platten um sie anschließen in einem anderen Rechner zu formatieren und dann wieder zu integrieren.
Anstandslos wurde die Platte vom Sil3114 Controller wieder aufgebaut.
Klingt doch schon mal gut. Aber ein zweiter Test, und es stellte sich heraus, dass dies wohl mein Glück war, schlug jedoch fehl, nachdem ich die andere Festplatte nach der ersten Wiederherstellung ebenfalls formatiert in den Verbund steckte, wurde das Raid plötzlich nicht mehr erkannt.
Okay..... Toll.
Also ist es mit einem 20Euro Controller wohl nicht abgetan.

Übrigens benutze ich ein Backplane mit 4 HDD Einschüben von Chieftec, welches einwandfrei und sicher funktioniert. :)

Nachdem ich dann genug von Silicon Image hatte las ich mir einige RAid-Controller Tests durch und kam letztendlich zu 3Ware.
Ich bestellte den Hardware-Raid-Controller 9650-LP2 SATA II mit PCI-E 1x Anschluss.

Dies stellte sich als Treffer heraus, denn der Controller stellte beide Laufwerke abwechselnd formatiert wieder einwandfrei her, auch wenn die Initialisierung eine halbe Ewigkeit gedauert hatte.
Juhuuu, dann wäre auch das geklärt! :)

Als Netzteil verbaute ich ein 400W Enermax Liberty Netzeil, welches bisher anstandslos funktioniert.

Soooo, soweit war der Server fertig. Aaaaber einige Modifikationen waren dennoch noch fällig.
Schließlich soll er die nächsten Jahre seine Arbeit auf dem Dachboden verrichten und ich komme vielleicht nur einmal im Monat rauf, um die Luftfilter zu reinigen.
Nebenbei: Trotz dass der Dachboden staubig wie "Sau" ist, sind die Filter immer noch recht frei von Staub, da so gut wie keiner aufgewirbelt wird. :)

Aber weiter mit den Modis:
Unser Haus ist nun ca. 35 Jahre alt und der Dachboden ist nicht isoliert.
Das heisst, dass es im Hochsommer dort oben kocht und letzten Winter habe ich bereits Temperaturen von nur knapp über 0°C gemessen.
Keine guten Voraussetzungen für den Betrieb. Vor allem im Winter, da sich der Server nach 2 Stunden in den stromsparenden S3-Modus fährt, wo nur noch gemessene 5,5Watt anstatt der 75Watt verbraucht werden.

Also überlegte ich mir, ob ich den Server im Winter nicht durchlaufen lassen sollte.
Nee, zu viel Stromverbrauch.
Also wurde im ersten Schritt das Gehäuse isoliert. Dies machte ich mit einer selbstgebauten Styrodurschale, welche ich noch mit mehreren Lagen Mylarfolie umwickelte und damit erhoffe ich mir, dass das Klima im Server sich einigermaßen hält, bzw. die Hitze im Sommer weitestgehend abhält, sowie den Temperaturverlust im Winter reduziert.

Das ist aber natürlich noch nicht alles.
Was wenn der Server mal eine ganze Nacht aus ist, was durchaus vorkommen soll? :D
Dazu baute ich mir eine Festplattenheizung, welches über eine Temperatursteuerung und einem unabhängigem Netzteil gesteuert wird.
Dazu habe ich Heizfolien besorgt, welche normalerweise zum Nachrüsten für Aussenspiegel gedacht sind, und je Folie ca. 11Watt Heizleistung verbraucht.
Ursprünglich waren 3 Folien für je eine Festplatte eine gedacht. Es stellte sich aber heraus, dass zwei Folien zwischen den drei Festplatte ausreichen.
Die Folie heizt sich um ca. 30°C über die Lufttemperatur auf.
Den Messfühler verbaute ich unter die dritte Festplatte, da es hier zuletzt warm wird.

Bei 8°C schaltet sich die Heizung automatisch ein und heizt solange, bis am Messfühler 10°C erreicht werden.
Dies dauert, und das ist noch ungetestet, da ich erst Tests bei Raumtemperatur durchgeführt habe, jedoch mit höheren Einstellungen, wohl ca. 1 - 2 Stunden, bis die Festplatten aufgeheizt sind.

Somit sollten die Festplattenlager ständig warm bleiben, da sie somit eigentlich nie kalt werden, da nach dem Fahren in den S3-Modus die Platten auf die Einschalttemperatur abkühlen und der Temperatursensor zuerst kalt wird.
Der Verbrauch der Heizung liegt bei gemessenen 27Watt, was aber immer noch wesentlich weniger als die 75Watt Verbrauch des Servers sind.

Ihr fragt Euch sicher, warum so ein System 75 Watt verbrauchen kann?
ca. 20Watt werden von den Lüftern geschluckt. Also das System selber bedient sich mit ca. 55Watt.

Zu den Lüftern:
Da auf dem Dachboden die Lautstärke egal ist und im Sommer eine gute Durchflutung notwendig ist, habe ich mich dazu entschieden hochtourige Server-Lüfter aka YS-Tech zu verbauen. Welche bereits im Server von Anfang an waren.

Freilich kann auch mal ein Lüfter ausfallen und ich denke der Gehäuselüfter ist der wichtigste. Da die Komponenten von seiner Zuluft abhängig sind, wo doch auch die Luftfilter noch dazu dranhängen.
Also ließ ich bei einem Bekannten eine Steuerung entwerfen, welche es ermöglicht, dass ein Reservegehäuselüfter anspringt, sobald eine bestimmte Grenze des Tachosignals des Hauptgehäuselüfters unterschritten wird. Zb. bei einem Lagerfresser oder Motorschaden, was ja durchaus vorkommen kann.
Ich habe also die Steuerung nach dem Plan des Bekannte ge- und verbaut.
Dabei habe ich 2 Gehäuselüfter hintereinander verbaut.
Auf den letzten Fotos ist es einigermaßen zu erkennen.

Ein Video mit dem Testlauf der fertigen, aber noch nicht abgeschnittenen Platine und ein Vergleich zum ersten Prototypen könnt ihr hier anschaun und runterladen:
http://www.buechl-city.de/dungeonkeeper ... 296_PC.avi

Somit ist das System nun bereits gut gesichert und ich hoffe, dass es den Winter so gut übersteht, wie ich es mir vorstelle.

Als letztes plante ich noch eine Steuer- und Infokonsole, wo ich den aktuellen Status abrufen kann.
Folgendes wird angezeigt:

- On-LED (Grün) (blinkt im S3, sollte aber eh den meisten hier bekannt sein :D )
- HDD-Zugriffs-LED (Blau)
- Lüfternotfallssystem ein (gelbe LED)
- Heizung aktiv (rote LED)
- Summer für die Steuerplatine wo der Netzteillüfter zur Überwachung dranhängt. Sollte dieser ausfallen, ertönt ein netter schriller Ton.
- Ein- Aus-Schalter um das System bei Bedarf auszuschalten, wenn was sein sollte. Bisher habe ich ihn lediglich zum Einschalten benutzt.


Ein Video des ersten Probelaufs könnt Ihr hier sehen und downloaden:
http://www.buechl-city.de/dungeonkeeper ... 329_PC.avi


Seit Anfang August steht der NAS-Server nun auf dem Dachboden, wo er bisher sang- aber nicht klanglos :D seinen Dienst als bisher und hoffentlich auch in Zukunft sicherer und zuverlässiger Weise erledigen soll.
Die CPU-Last im Idle ist sehr gering und treibt sich meist bei unter 5% herum.
C&Q ist aktivert, welches die CPU bei geringer Last auf 800MHz heruntertaktet.
Jeden Freitag findet eine Verifizierung des Raid-Verbundes durch die 3Ware-Software statt.
Sollte mal was zu heiss werden, habe ich via Everest Profile erstellt und ich bekomme eine E-Mail Warnung geschicht.

Anbei noch eine kleine Fotoreihe vom Aufbau ab dem AMD 2650e-Verbund.

Viele Grüße,

Stefan

Montage der ersten Komponenten
Bild

Bild

Bild

Bild

Bild

Die CPU wird erkannt
Bild

Nachdem sich herausstellte, dass der Chipsatz zu heiss wurde, bekam dieser einen Lüfter verpasst.
Bild

Nach 11 Stunden Memtest noch kein Fehler :)
Bild

Die Backplane ist drin!
Bild

Bild

Ein früher Run
Bild

Drei süße Festplatten
Bild

Noch völlig leer
Bild

Kabelsalat bei der Vorbereitung der Konsole
Bild

unten mitte sieht man die Steuerplatine für das Lüfternotfallsystem und oberhalb rechts die beiden 120mm Lüfter im Huckepack
Bild

Die Temperatursteuerung für die spätere Festplattenheizung noch unverbaut
Bild

Drei Heizpads; Laut Angabe 8W, gemessen jedoch ca. 11W
Bild

LED-Test der Konsole mit aktivierter Heizung und Lüfternotfallsteuerung
Bild

Die Platine der Lüfternotfallsteuerung
Bild

Bild

Fast final und etwas Photoshop
Bild

Fertig auf dem Dachboden; Man sieht links durch den drehenden Lüfter den Ersatzlüfter, welcher steht. Der Durchsatz wird dadurch kaum beeinträchtigt.
Bild

Bild

Bild

Konsole im (noch immer :D ) unbedrucktem Zustand
Bild
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

Benutzeravatar
larry
Moderator
Beiträge: 9925
Registriert: 22. Dez 2007, 16:13

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von larry » 8. Sep 2010, 19:42

Ich glaube du hast hier den ersten Server mit eingebauter Heizung.

Gefällt mir.
Mein Server steht auch auf dem Dachboden. Im Winter bekomme ich dann immer ein ungutes Gefühl, wenn die Plattentemperatur unter 5 Grad fällt.

Gruß
Larry
Hauptserver: Intel I3-2100, MSI H67MA-E45, WHS 2011
System: Corsair Force GT 90GB - Datenplatten: 2*Seagate 3TB + ext. WD 500 GB für Serversicherung(nur System),8 GB Ram, Fractal Design R3, be quiet! L7-300W, 2*Digital Devices cineS2(Mediaportal)
Archivserver: Intel Cel.G530, Intel DB65AL, WHS 2011, Drivebender
System: SamsF4 320GB - Datenplatten: 5*2TB SamsF4. + VHD für Serversicherung(nur System), 4 GB Ram, Lancool K-11X, be quiet! L7-300W
Backupserver: AMD Athl. X2 4850e, Gigabyte GA-MA780G-UD3H, 3*Asrock SATA3 + 1* DeLOCK 70154 SATA Controller, WHS 2011, Drivebender
System: SamsF4 320 GB - Datenplatten: 15 diverse Platten + VHD für Serversicherung(nur System) ,4 GB Ram, Seasonic ss 330 Watt
Router: AVM FRITZ!Box 7270, Kabel Deutschland
Clients: 2* HTPC, Win7 HP 32 Bit - 2*Arbeitsrechner Win7 HP 64 Bit - 1*Laptop Win7 HP 32-Bit

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 8. Sep 2010, 21:18

Hallo Larry!

Vielen Dank! Freut mich, dass er Dir gefällt!
Ich habe mich mal hier umgesehen und bisher noch keinen weiteren Server mit HDD-Heizung gesehen :D

Ist Dein Dachboden auch nicht isoliert?
Hat Dein Server schon einmal einen Winter überstanden?
Wie hast Du ihn handgehabt?
Hast Du ihn durchlaufen lassen, der in den Stby geschickt?

Besten Dank schonmal :)


Gruß
Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

Benutzeravatar
larry
Moderator
Beiträge: 9925
Registriert: 22. Dez 2007, 16:13

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von larry » 8. Sep 2010, 23:36

Hallo Stefan,

mein Server geht immer in Standby. Habe bei mir schon seit Jahren einen Rechner auf dem Speicher stehen. Dort ist auch nichts isoliert.
Bisher keine Probleme. So etwas darf man ja nicht sagen. :D

Gruß
Larry
Hauptserver: Intel I3-2100, MSI H67MA-E45, WHS 2011
System: Corsair Force GT 90GB - Datenplatten: 2*Seagate 3TB + ext. WD 500 GB für Serversicherung(nur System),8 GB Ram, Fractal Design R3, be quiet! L7-300W, 2*Digital Devices cineS2(Mediaportal)
Archivserver: Intel Cel.G530, Intel DB65AL, WHS 2011, Drivebender
System: SamsF4 320GB - Datenplatten: 5*2TB SamsF4. + VHD für Serversicherung(nur System), 4 GB Ram, Lancool K-11X, be quiet! L7-300W
Backupserver: AMD Athl. X2 4850e, Gigabyte GA-MA780G-UD3H, 3*Asrock SATA3 + 1* DeLOCK 70154 SATA Controller, WHS 2011, Drivebender
System: SamsF4 320 GB - Datenplatten: 15 diverse Platten + VHD für Serversicherung(nur System) ,4 GB Ram, Seasonic ss 330 Watt
Router: AVM FRITZ!Box 7270, Kabel Deutschland
Clients: 2* HTPC, Win7 HP 32 Bit - 2*Arbeitsrechner Win7 HP 64 Bit - 1*Laptop Win7 HP 32-Bit

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 9. Sep 2010, 04:56

Ohhh, bitte keine schlechte Omen und böse Geister freilassen :)

Die Festplatten scheinen wohl mehr abbekommen zu können, als ich dachte.

Ich fürchte zwar nicht um die Platten oder die Elektronik. Aber dafür um die Flüssigkeitslager. Die EADS müsste Flüssigkeitsgelagert sein.
Und wenn das Öl oder was immer da als Gleitmittel benutzt wird recht "zäh" wird, tut sich auch der Motor schwerer, das Ding anlaufen zu lassen, was vielleicht die Lebensdauer verkürzt und ich habe vor, den Server die nächsten Jahre so zu lassen, solange er läuft.
Deswegen die Idee mit der Heizung :)

Gruß
Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

MSP1978
Foren-Mitglied
Beiträge: 125
Registriert: 6. Jan 2010, 07:39
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von MSP1978 » 9. Sep 2010, 07:50

Moin,

feiner Server, die Idee mit der Heizung ist auch klasse.

Oben schreibst Du aber was von RAID... Du weist schon dass der WHS dafür garnicht gedacht ist und M$ davon abrät dieses mit dem WHS zu nutzen?

Was hast Du in Summe für den Server eigentlich bezahlt mit allem drum und dran? Benutzt Du auch eine USV oder planst Du diese noch einzusetzen?

Gruss,
Michael
Server: HP Microserver Gen8, ESXi 5.5 Upd.3, Server 2012 R2 Standard
Clients: PS3, 1x Windows 8.1 Professional, LAN-Drucker, 1x MacBook Pro, 1x iPad 1, 1x Android, 1x Windows Phone 8.1
Netzwerk: 3x 200MBit Powerline-Adapter ALLNET ALL168205, Gigabit-Switch, 100.000kBit Unitymedia IPv3

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 9. Sep 2010, 15:21

Servus Michael,

Also erstmal mercie auch Dir!

Das Raid 1 klappt perfekt. Zwei WD20EADS sind als Raid 1 am 3Ware 9650SE-LP2 Controller dran. Die Windows 2003 Treiber klappen perfekt. Ebenso die jeden Freitag stattfindende Verifizierung.
Auch das Einrichten war überhaupt kein Problem.
Ich weiß nicht, was M$ dran schlecht finden soll?

Bitte klär mich mal auf, denn seit 4 Monaten läuft der Server ohne jegliches Problem. :)

Eine USV ist dran, und zwar die APC Back-UPS RS1500LCD.

Puh... Die Kosten...

Mit ca. 1200.-EUR war ich dabei ohne jetzt die Fehlkäufe also das Serverboard, dasGeodeSystem und den dummen DeLock Raid-Controller hinzuzurechnen, aber die machen nimmer sooo viel aus, dürften ca. 100.-EUR sein.

Ich glaube, mit den mittlerweile gefallenen Preisen sollte dieser Server jetzt auch vielleicht sogar für unter 1000.-EUR zu realisieren sein.

Gruß Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

MSP1978
Foren-Mitglied
Beiträge: 125
Registriert: 6. Jan 2010, 07:39
Wohnort: Mönchengladbach
Kontaktdaten:

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von MSP1978 » 10. Sep 2010, 07:55

Moin Stefan,

wegen dem Raid...

M$ sagt dazu auf seiner Seite erstmal Werbewirksam das hier...
Unterstützt Windows Home Server RAID?

Windows Home Server bietet die Vorteile von RAID (Redundant Array of Independent Disks), allerdings ohne die hiermit einhergehende Komplexität. Unter Windows Home Server können neue Festplatten beliebiger Größe (intern oder extern) hinzugefügt werden, und die verfügbare Speicherkapazität wächst entsprechend. Bei einem System mit zwei oder mehr Festplatten können die Benutzer von Windows Home Server die "Duplizierung" auf der Basis von freigegebenen Ordnern aktivieren, und die Dateien werden auf zwei separate Festplatten kopiert oder "gespiegelt". Wenn eine der Festplatten ausfällt, verliert der Benutzer keine Dateien in Ordnern, für die die "Duplizierung" aktiviert wurde. Externe Festplatten können über USB, Firewire oder eSATA angeschlossen werden, sofern der Computer mit Windows Home Server über die entsprechenden Eingänge und Anschlüsse verfügt.
Ansonsten steht auch viel im Forum hier. Es KANN laufen, wird aber nicht Empfohlen. Ist zwar eine Empfehlung von M$ selber, aber der schenk eich pers. auch mal glauben. DIe integrierte Funktion tut es ja ohne Probleme aktuell.. ;)

Wenn es bei Dir läuft super. Mir wäre pers. ein echtes Raid auch lieber gewesen, aber den DriveExtender finde ich auch recht gut, neue HDD anstöpseln und gut ist :)

Gruss,
Michael
Server: HP Microserver Gen8, ESXi 5.5 Upd.3, Server 2012 R2 Standard
Clients: PS3, 1x Windows 8.1 Professional, LAN-Drucker, 1x MacBook Pro, 1x iPad 1, 1x Android, 1x Windows Phone 8.1
Netzwerk: 3x 200MBit Powerline-Adapter ALLNET ALL168205, Gigabit-Switch, 100.000kBit Unitymedia IPv3

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 10. Sep 2010, 15:18

Ach, jetzt versteh ich. M$ meint, dass Raid durch die WHS-Duplizierung unnötig sei, auch wenn es nicht den Funktionsumfang eines Raids hat.

Das stimmt, da gebe ich ihnen Recht.

Aber wenn eine der beiden Platten am Raidcontroller mal den Geist aufgibt, dann spare ich mir die Systemwiederherstellung, da ich die neue Festplatte nur einschieben brauche (ok, in meinem Fall vorher noch Heizpad anbringen :D ) und einscheiben brauche. Anschließend macht der 3Ware-Controller sein Rebuild.
In der Zweischenzeit kann man auch mit nur einer Festplatte weiterfahren.

Und genau das war auch der Grund, warum ich mehr für den Raid-Verbund ausgegeben habe.

Also 2 2TB Platten sind am Raidcontroller und spiegeln Betriebssystem sowie auch Daten und die dritte 2TB Platte habe ich über WHS als erweiterten Speicher hinzugefügt.
Dadurch habe ich eine enorme Redundanz, die nochmal dadurch verstärkt wird, dass alle Daten auch nochmal an meinem Arbeitsrechner "gesichert" sind.

Schöne Grüße :)

Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

sTunTe
Moderator
Beiträge: 3078
Registriert: 9. Jun 2008, 16:25
Wohnort: im nasskalten Norden

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von sTunTe » 10. Sep 2010, 16:50

DungeonKeeper hat geschrieben:Ach, jetzt versteh ich. M$ meint, dass Raid durch die WHS-Duplizierung unnötig sei, auch wenn es nicht den Funktionsumfang eines Raids hat.
Darüber kann man sich streiten.
Ich für meinen Teil kenne keinen (bezahlbaren) Controller, bei dem man den Speichplatz so beliebig erweitern kann wie beim WHS.
Spätestens wenn alle Ports des Contoller voll sind, stößt man hier an die Grenzen und muss entweder auf einen größeren Controller ausweichen, oder einen weiteren Controller mit mindestens 2 Platten bei RAID1, bzw. 3 Platten bei RAID5 anklemmen.
Beim WHS hingegen fügt man genau eine Platte hinzu.
Sind alle Ports belegt, kein Problem.
Einfach einen simplen SATA-Controller rein und weiter gehts.
DungeonKeeper hat geschrieben:Aber wenn eine der beiden Platten am Raidcontroller mal den Geist aufgibt, dann spare ich mir die Systemwiederherstellung, da ich die neue Festplatte nur einschieben brauche (ok, in meinem Fall vorher noch Heizpad anbringen :D ) und einscheiben brauche. Anschließend macht der 3Ware-Controller sein Rebuild.
In der Zweischenzeit kann man auch mit nur einer Festplatte weiterfahren.
Hast Du dieses Szenario schon getestet?
Ich hatte bei meinem WHS ursprünglich auch die Systemplatte über einen (zugegeben) lausigen Onboard-Controller gespiegelt.
Als dann eine der beide Platten den Geist aufgegeben hatte, war der Controller nicht in der Lage die Spiegelung OnTheFly wiederherzustellen, sondern nur im BIOS des Controllers.
Dauer des Rebuilds für 500GB: 8 Stunden.
In der Zeit hätte ich den WHS mehrmals neu aufsetzen können, inkl. Anlegen der Benutzer, installieren von Addins und zusätzlicher Software.
In meinem Fall war dass das K.O.-Kreterium für eine gespiegelte Systemplatte.

Außerdem wurde hier im Forum schon mehrmals darüber berichtet, dass nach einem Rebuild die Festplatten-ID nicht mehr mit der alten übereinstimmte und der WHS damit seine eigene Systemplatte nicht mehr kannte.
Ist aber wohl vom verwendeten Controller abhängig...
DungeonKeeper hat geschrieben:Und genau das war auch der Grund, warum ich mehr für den Raid-Verbund ausgegeben habe.
Womit Du Dich aber ganz klar von der eigentlichen Zielgruppe des WHS abhebst. ;)

Gruß
sTunTe

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 10. Sep 2010, 17:34

Hast Du dieses Szenario schon getestet?
Selbstverständlich. Im Text oben habe ich es bereits erwähnt.

Ich habe zuerst mit einem DeLock Controller mit SilImage3114 Chip getestet, aber das war billigster China-Schrott. Absolut unbrauchbar.

Danach habe ich einen wesentlich teureren 3Ware 9650LP Controller gekauft (http://www.3ware.de)
Dieser machte die Rebuilds ohne Probleme mit. WHS zeigte sich davon völlig unbeeindruckt.

Weitere Platten wie zb. die dritte 2TB Platte fügte ich ganz normal über WHS hinzu. Weitere Platten sind selbstverständlich kein Problem.
Es begrenzt nur der Freiraum im Server.

Abheben möchte ich mich nicht von der Masse. Dies geschieht eher aus den Umständen.
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

sTunTe
Moderator
Beiträge: 3078
Registriert: 9. Jun 2008, 16:25
Wohnort: im nasskalten Norden

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von sTunTe » 10. Sep 2010, 20:05

DungeonKeeper hat geschrieben:Danach habe ich einen wesentlich teureren 3Ware 9650LP Controller gekauft
Wäre interessant zu wissen, welchen aus der Serie.
Falls es der 4-Port ist, kostet der Controller alleine soviel wie bei einigen anderen der komplette Server inkl. Platten. ;)
DungeonKeeper hat geschrieben:WHS zeigte sich davon völlig unbeeindruckt.
Da das Betriebssystem keine Ahnung von den physikalischen Platten hat, ist das auch kaum verwunderlich.
Und den Rest besorgt der verbaute RISC-Prozessor.
DungeonKeeper hat geschrieben:Abheben möchte ich mich nicht von der Masse. Dies geschieht eher aus den Umständen.
Mach Dir nichts draus.
Mit 13 verbauten Platten und einem Quadcore-Prozessor gehöre ich eigentlich auch nicht zur Zielgruppe. ;)

Gruß
sTunTe

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 10. Sep 2010, 20:31

Angeben möchte ich auf keinen Fall, dafür habe ich den Server nicht gebaut. :D
Er erfüllt den Zweck, für den ich ihn brauche :)

Oh, ich habe überlegt, ob ich den 4Port brauche, aber da ein Raid1 vollkommen reicht, habe ich den 2 Port genommen.
170.-EUR sind reichlich für einen Raid-Controller, aber ich finde er ist wirklich jeden Cent wert.
Den einzigen Nachteil, den ich bisher gefunden habe, ist die Wärmeentwicklung. Habe darum noch einen Lüfter darüber verbaut.

Ja ein Quad und 13 Platten sind schon was anderes! :) :D
Ich vermute mal, dass auch Dein Server die Hardware für Deinen Verwendungszweck auch braucht.

Schöne Grüße

Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

sTunTe
Moderator
Beiträge: 3078
Registriert: 9. Jun 2008, 16:25
Wohnort: im nasskalten Norden

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von sTunTe » 10. Sep 2010, 21:25

DungeonKeeper hat geschrieben:Ja ein Quad und 13 Platten sind schon was anderes! :) :D
Ich vermute mal, dass auch Dein Server die Hardware für Deinen Verwendungszweck auch braucht.
Naja...
Plattentechnisch stoße ich langsam an die Grenzen, zumindest mit der derzeitigen Hardware.
Es passt noch eine rein, dann ist schicht. :(
Allerdings werde ich bei der nächsten Platte anfangen, die "kleinen" 500er auszumustern.
Davon sind noch 4 Stück verbaut.
3 davon wandern in meine Workstation als RAID0, die vierte bleibt als Systemplatte drin.

Da noch 3 virtuelle Maschinen auf der Kiste laufen, stoße ich auch mit dem Arbeitsspeicher an die Grenzen.
Allerdings nur wegen des Betriebssystems, nicht wegen des Boards.

Die CPU ist mit durchschnittlich 25% Auslastung gut gewählt und mit 4x 2,5 GHz ausreichend schnell.

Lediglich das Mainboard war ein absoluter Fehlgriff.
NIE WIEDER DFI!!! :evil:

Gruß
sTunTe

Benutzeravatar
DungeonKeeper
Foren-Einsteiger
Beiträge: 27
Registriert: 6. Sep 2010, 18:22
Wohnort: Im tiefsten Niederbayern

Re: Mein Spezial - NAS-Server Eigenbau - NX-05

Beitrag von DungeonKeeper » 11. Sep 2010, 14:15

Hi Leute! :)

Mittels dieses kleinen Bausatzes http://www.conrad.de/ce/de/product/1921 ... Detail=005 kann ich nun endlich auch die Temperatur des Gehäuseinneren messen, ohne dass er Laufen muss. Habe den Sensor in der Mitte des Gehäuses verbaut.
Die übriggebliebenen vier Steuerleitungen sind nun auch belegt, da die Steuerleitung 16 Adern besitzt.

Bild

Gruß Stefan
O---NX-05---O
AMD Neo MV-26 1,6GHz, 15W
Kingston ValueRAM 2 GB ECC DDR2-800 Kit
ASUS M4N78-AM, GeForce 8200
3ware 9650SE-2LP Kit Raid Controller
3 x Western Digital WD20EADS, 2 x WD20EADS @ Raid 1 (System), 1 x WD20EADS @ MB-SATA Port
Fantec TCG-4860KX07, 4HE 19" Rack, Isoliert
Festplattenheizung, Emergency Aux Fan System, Statuskonsole
Stdby: 5W - Sommermodus: 75W - Wintermodus: 55W - HDD-Heizung: 27W
viewtopic.php?f=23&t=11394

Antworten