Seite 2 von 2

Re: Lights-Out on DSM 7

Verfasst: 29. Sep 2021, 19:20
von Etupes25
I have upgraded to the latest beta on the server and console side.
There is a different error message with the console now: Bad Gateway (502)

I couldn't find the right directory for the logs on the NAS. The instructions above mention this directory:
cd /share/CACHEDEV1_DATA/.qpkg/LightsOut/log/

I am guessing the "/share/" part refers to an obvious place, but I don't know it.

Here are the logs from the console:
2021-09-29 10:04:57:953 [ 13] DEBUG MulticastClient.EndReceive: Found ZPCloud, Version 3.7.0.4784, IP 192.168.1.200
2021-09-29 10:04:58:010 [ 1] DEBUG UserCredentials.SetDefaults: Settings.Default.Server
2021-09-29 10:04:58:010 [ 1] DEBUG UserCredentials.SetDefaults: Environment.MachineName ZP1
2021-09-29 10:04:58:464 [ 1] DEBUG UserCredentials.ServerFound: 3
2021-09-29 10:04:58:464 [ 1] DEBUG UserCredentials.ServerFound: Adding ZPCloud 3.7.0.4784 192.168.1.200
2021-09-29 10:04:58:473 [ 1] DEBUG UserCredentials.SetDefaults: Ntlm False
2021-09-29 10:04:58:473 [ 1] DEBUG UserCredentials.RetrieveCredentials: Not found
2021-09-29 10:04:58:473 [ 1] DEBUG UserCredentials.SetDefaults: SavePW False
2021-09-29 10:05:10:919 [ 1] DEBUG ---- UserCredentials.BtnLoginClick ----
2021-09-29 10:05:10:919 [ 1] DEBUG UserCredentials.Login: start to get access token
2021-09-29 10:05:10:919 [ 1] DEBUG Testing with Tls, Tls11, Tls12=4032 -
2021-09-29 10:05:11:974 [ 11] DEBUG Success BadGateway
2021-09-29 10:05:11:974 [ 1] DEBUG GetResourceOwnerTokenAsync: serverUri=https://zpcloud:7783/, credential=[Replaced Username here], otp=
2021-09-29 10:05:11:974 [ 1] DEBUG Started resource owner token request for [Replaced Username here] on https://zpcloud:7783/token
2021-09-29 10:05:11:996 [ 1] ERROR Can't get token, HttpErrorStatusCode=BadGateway, HttpErrorReason=Bad Gateway

Re: Lights-Out on DSM 7

Verfasst: 29. Sep 2021, 19:36
von Martin
Bad gateway indicates that either the remote proxy is not working or Lights-Out has not been fully running.

The command
cd /share/CACHEDEV1_DATA/.qpkg/LightsOut/log/
has to be entered on your NAS after you connect via ssh. Please read the help again.

Regards
Martin

Re: Lights-Out on DSM 7

Verfasst: 30. Sep 2021, 00:03
von Etupes25
OK I entered the following command and it worked this time
cd /var/log

The file is on its way through email. Thank you for your quick responses!

Re: Lights-Out on DSM 7

Verfasst: 30. Sep 2021, 08:55
von Martin
Ah, you're right. The command is for QNAP, will fix that.
Logs received, will check now.

Regards
Martin

Re: Lights-Out on DSM 7

Verfasst: 4. Okt 2021, 18:24
von Etupes25
Hi Martin,

The 3.7.0.4785 beta version works well.

I have the server installed on DSM 7.0 and 2 windows clients. The server wakes up the computers a few moments before Active backup for Business is supposed to start (schedule set in ABfB on the NAS). The LO3 server reports the start time and finish time of the computer ABjB tasks.
I have set LO3 to make the computers sleep after 30 mn of inactivity during the day, except when a backup task is still running.

A minor nit: when I check the times I noticed the LO3 server is reporting the backup task started at 6:59am and finished at 7:01, while the task is set to start at 7:00am and while ABfB reports the task has started at 7:00:03 and finished at 7:01:47. I guessed it was a rounding artifact

Since the backup tasks run pretty fast on my computers, I have not fully tested whether the computer goes back to sleep later when the backup is running than when no backup is running. I will test that today and report back.

Re: Lights-Out on DSM 7

Verfasst: 4. Okt 2021, 23:48
von Etupes25
I have noticed something today that was not happening in the first 24 hours.

On the Windows client, when no backup is running, during the course of the day. the computer goes to sleep roughly after the time set up in LO3 server, computer properties. I say roughly because I have set up that time to 5mn, but the computer goes to sleep after 8, 6, or 9mn of inactivity.

But more concerning is the fact that, when I wake up the computer following that, there is a LO3 Window still active on the screen, telling me that the computer will get back to sleep within 1mn. The 1mn is pretty consistent. I can click cancel to keep the computer awake. If I don't, the computer is falling back to sleep.

I didn't notice within the first 24 hours, but maybe another user got to dismiss the window.

I will send you the windows client logs by email.

Re: Lights-Out on DSM 7

Verfasst: 16. Mai 2022, 23:50
von milleron
I just updated my Synology DS 718+ to DSM 7 today (and subsequently to 7.1) and didn't think to check this forum. My Lights-Out 3.7.1.4855 is no longer working. I'm unable to download the beta you linked in 2021. At this point, I see no posts for more than six months. Have you given up on making Lights-Out work on an upgraded Synology NAS or is there another L-O-3 beta for download somewhere?

Ron

Re: Lights-Out on DSM 7

Verfasst: 17. Mai 2022, 09:13
von Martin
Please download the DSM 7 package here: https://www.green-it-software.com/downloads/
and follow the installation instructions here https://help.green-it-software.com/help ... yNAS7.html

Regards
Martin