[info] Acer easyStore h340 with possibly fried NIC recovery - my journey

Fragen zum Thema Windows Home Server Hardware
Beiträge: 2
Registriert: 14. Sep 2018, 02:16

[info] Acer easyStore h340 with possibly fried NIC recovery - my journey

Beitrag von Krzyś » 16. Sep 2018, 02:03

Pardon me for writing in English. Ich habe Deutsch gelernt, aber ich habe fast alles vergessen.

TL&DR; Got bare server without HDDs and recovery media - with seemingly fried NIC. Restored it to working condition (with caveats).

Long version:

Last week I've received Acer easyStore H340 server. Bought second-hand in unknown condition (it powered on, though). Unit had VGA out, so I assumed it was a graphics card installed. No accessories whatsoever - no recovery media, no HDDs, even no caddies.

Unit was probably collected from trash. VGA on the back suggested power user - not good, as this might suggest that it is severely broken. (Fried NIC seems to be very common fault.)

Indeed, the unit powered on. VGA out was just a debug cable (good - I could reuse it in my HP DataVault X310 - also I could still install PCIe card). The issue was that NIC was seemingly not working - it did not light-up after powering the system.

Debug jumper was installed by default. When PXE bootrom kicked in, it complained about not connected media (contrary to the reality). But after PXE bootrom returned execution to BIOS (for that dreadful "No bootable device" from int18h AFAIR), the lights on the NIC were glowing. Next try of network booting brought message that bootrom failed to configure the NIC.

Blinking network lights, once initiated by PXE bootrom complaining about not connected cable, persisted even after powering the unit down (without cutting off the mains, of course). But after next start, during PXE bootrom attempts to boot from network, they were going down - again with message that no cable is connected. After PXE bootrom returned, lights were again blinking. And so on.

The blinking was in odds with the manual - users manual said that amber is gigabit ethernet, green is fast ethernet. It was blinking almost exclusively in green, despite being connected to gigabit switch (however on some occasions it was blinking in amber)

Internal flash was probably empty, since it never booted to Windows PE that should be there. Sometimes there was an endless loop of "No bootable device" (or similar, I don't remember), being printed in a succession (different scenario than the one mentioned previously).

As far as booting from USB goes, I've been unable to boot it from either USB HDD or USB CD - both were not recognized.

I've managed to boot it from USB floppy drive, I've also succeeded in booting it from Bart's (of BartPE fame) modular network MS-DOS bootable disk, however didn't tried much more as I had no Yukon driver on it.

I've also tried booting iPXE from floppy, however it hung every time it waited for NIC initialisation and there was network cable connected.

I've tried booting from SATA Blu-Ray (the only SATA Optical Drive I had) connected to onboard SATA connector. It worked but was a bit flaky - sometimes it booted a bit further, sometimes it hanged earlier - the same symptoms observed when dealing with bad RAM. I couldn't boot anything more complicated like Linux distro. However, I've managed to boot memtest and 4 or 5 full passes passed before I turned off the system. So probably it is not a memory, since such a catastrophic boot failure should have manifested itself early in memtest.

Also during all those struggles to get something booted from some media, I've seen "Parity check 10000" message several times (after which I had to power cycle the unit). Mr. Google remembers that message from late 90's and provides nothing very useful (after a quick glance).

On Friday I've received some URLs from Nobby1805 (I'm extremely grateful to him). Among them there were internal flash images of h340 & h341.

h340 one was in Acronis True Image backup format. I've written my journey of getting these extracted here: https://rlevchenko.com/2015/05/21/how-t ... ment-29096

(Eventually I took h341 files - that was just an archive of files from internal flash - copied these files to external USB SATA HDD, copied MBR code to that HDD (first 440 bytes - after these 440 bytes serial number of the volume is stored), set first ntfs partition as active (first byte of partition description to 0x80) and in this way I had working recovery HDD.

(As it didn't worked via USB, I've eventually connected it to the SATA1 port)

But it is still no good without working ethernet. And NIC haven't magically started working.

Today, I've butchered together a new recovery image - I've took my customised WIM from HP DataVault x310 that spawns additional cmd.exe and dropped the required drivers (+ additional driver for USB ethernet dongle), though I'm not entirely sure if I did it right - dism didn't wanted to modify my image, peimg.exe just inserted some stuff in Windows\Inf (but no driver binaries in \Windows\System32\Drivers!) - so just in case I've put all the files in \Drivers and paths to individual .inf files in \Drivers.lst. (My custom HP DataVault x310 recovery (WinPE) image had - apart from additional cmd.exe spawned at startup - autostarting vnc server - I had no debug cable for my HP DataVault x310 so I've been helping myself via VNC. Long story short, after hacking DataVault's restore wizard to talk to my server (by default it requires direct cable connection between h310 and PC on which the restoration is performed - so it spawns its own thtpd32 and then watches its logs for message that denotes successful upload of recovery WIndows PE image, then grabs grabs the other party IP from the log and uses it to push Windows Home Server - as I already had DHCP, PXE, TFTPD on my home network and certainly didn't wanted to mess with my config, I had to change it so it would just connect to specified IP and nothing else), it turned out that I had recovery image in wrong directory. HP wizard excepted "Recovery Image", I had just "Recovery" - just because that old ISO packer plugin in Total Commander used ISO9660 directory name instead of UDF directory name and for me "Recovery" looked valid enough. Should I've burned the ISO to DVD, or even mounted it in some virtual drive, I wouldn't have fiddled for dome hours with that. Also, I wouldn't have lost (backed up possibly) content of some flash drive that I happened to have connected while using "Wipe everything" in HP recovery wizard.)

However, it didn't helped. ipconfig showed just at start one ethernet adapter with disconnected cable; afterwards (after "Verifying drivers" part was over) it showed just nothing (no ethernet adapter).

Having been tired by all of this, I've decided to just drop the HDD in HP DataVault x310 and do the restoration with it (using Acer provided wizard and Acer provided recovery image).

It went just fine, after the wizard exited, I've manually turned off the server (I forgot to include shutdown.exe in my boot.wim and the wizard assumed that exiting that recovery program would reboot the server - which didn't as my customised image spawned another cmd.exe).

Moved the disk back to the Acer easyStore h340 and turned it on. Windows loaded, configured itself just fine, rebooted and dropped me to the desktop.

The caveat is that I saw no wizard for detecting USB NIC, which should have popped up by default. Just nothing.

Internal (presumably fried) NIC was not detected either.

I've connected external DVD with USB NIC drivers. Nothing.

Both devices (along with USB pendrive) are detected as "Unknown devi" eeee pardon, "Unbekanntes Gerät" (as I have German WHS - if anyone got English version, I would be grateful, btw).

So it looks like USB is fried as well.

Keyboard for whatever reason works well (I don't know if it was due to the fact that it was first detected by BIOS emulation of legacy keyboard or something). I didn't bothered to connect the mouse to my h340 yet.

(In the meantime I've ordered double Gigabit Ethernet low profile NIC with PCIe x4 - double ethernet ports, because I don't like to waste that PCIe slot. Double ethernet would be better than single one. Now I guess that I would be better served with PCIe USB 3.0 host adapter.)

After restart (with cutting off mains for a while), there was a nice surprise - onboard NIC got detected. Hurrah! But well - still no cable. I've started fiddling with adapter settings - it turned out that it started working (and detecting network) once I set link type to 10 mbit/half duplex. (To be more specific - I had to pull out the cable and only then set it. With cable in, the whole server freezed first time.)

Eventually, I've managed to up this to 100 mbit full duplex. Way better - but still quite bad for storage server (!) (I'd rather see gigabit there). NIC is quite a bit tricky - if I set it to gigabit ethernet, ethernet controller disappears (Power cycling helps - with cutting off mains just in case). Or sometimes changing settings causes it to freeze the whole server.

I have it running for several hours now. As for a fried NIC, it is rock-solid stable - ping shows just 1 verlust paket and occasional >1ms pings. All in all as a backup solution/storage server it is possibly not extremely trustworthy but works anyhow.

Maybe PSU in my unit needs recapping? Or maybe something is more seriously broken. I don't know for now; also I wonder whether PXE would have worked if I connected it to 100 Mbps switch. Anyway, for now it is enough for me. Thank you for your attention.

And my special thanks for Nobby1805 - I'm very grateful for the images that enabled me to make any use of the server.


Added on Sunday, 16th September 2018, 13:29:

First of all it seems that connecting it to 100 mbps port enables it to even boot from PXE (actually, I've used PLC adapter with 100mbps port as I had that handy. Should I have connected it to 100 MBps port I probably wouldn't have noticed the trouble at the first sight). I've tried booting geexbox (originally it is a Linux distribution that turns PC into HTPC of sorts - I have that handy as a PXE payload and I'm using it for inspection/dumping HDDs of any foreign PCs I have). However, geexbox (re)initialisation of NIC was enough to render it not working. However, it seemed to detect internal flash, along with tons of USB errors. Internal flash detection was of no use for me, as I had nowhere to write the data dumped from it to.

As for WHS, the NIC operation is not entirely reliable. Sometimes it is just OK after cold boot, sometimes NIC is not detected. So far I had a success of booting with cable disconnected.

OTOH I've stumbled on an idea, that the issue with USB is of the same kind as with NIC. Low speed (1,5 mbps) and full speed (12 mbp) USB 1.x devices are fine (that's why keyboard works, that's why booting off floppy drive worked), high speed (480 mbps) USB 2.0 devices are not working (that's why I couldn't get it to boot from USB HDD or USB DVD, that's why it never recognized USB flash drive or USB 2.0 NIC). I've confirmed this is the case when I connected crappy USB 1.1 NIC masquerading itself as USB 2.0 in USB description field :) (but it is still only USB 1.1 device, despite the name presented to the operating system).

I've also confirmed this by using USB-over-UTP extension cord - I have a cord of this kind (it could be used to extend USB cable with Unshielded Twisted Pair cable - I mean the same cable as for ethernet), and since I bought the cheapest, it only works as USB 1.1, degrading any device connected to it to USB 1.1 speeds.

And now, my former "Unbekanntes Gerät" is detected as USB NIC, when connected via USB-over-UTP extension cord (and downgraded to USB 1.1 speeds). The same goes for pendrive and USB DVD (the latter does not read discs due to insufficient power, but it is detected just fine). Also USB stick is being detected by BIOS (and BIOS tries to boot it by default).

I've also managed to dump the internal flash to the USB stick connected via that USB-over-UTP cable (had to cat /dev/sda > /mnt/sda1/some-file-with-internal-flash as busybox in initrd of geexbox had no dd compiled in). Internal flash looks fine with all files necessary to boot recovery WinPE, however I didn't tested it actually on some other hardware.

The thing that bothers me is the fact, that state of the server will probably deteriorate over time. The issues I had booting from SATA bluray also might have to something with worsening health of the unit. Also I'm wondering what is causing both of these issues. I think I need to look for bulged capacitors on the mainboard or try to testing the PSU (voltage stability, maybe substituting it for known good one).

The question is, whether PCIe NIC or PCIe USB 3.0 card would work fine (or at all). Will see. In my exact case, as I've mentioned previously, USB 3.0 PCIe card along with USB 3.0 gigabit ethernet NIC would be more useful configuration, considering that everything else would be reliable.

Beiträge: 2
Registriert: 14. Sep 2018, 02:16

Re: [info] Acer easyStore h340 with possibly fried NIC recovery - my journey

Beitrag von Krzyś » 12. Okt 2018, 21:27

It seems that PCIe is dead as well.

Dual ethernet PCIe x4 NIC is not recognised at all.

USB 3.0 PCIe x1 controller causes booting process to hang on BIOS screen (before grey configuration summary).

As far as USB 3.0 PCIe x1 controller is concerned, I can make it detected (sort of), if I hotplug it after that grey configuration summary is over, however there are no resources free for it to work and Windows just reports error (and asks for reboot, which results - you've guessed it - in hang on BIOS screen).

(I haven't tried both cards in any other PC, but I doubt that both are not working.)

(In the meantime I've tried another PSU. No difference whatsoever.)

So I'm done with it. I could only use it as-is, with 100 mbps-capped network (I wonder - just out of curiosity - whether 10 mbps would be more robust, since 100 mbps is still somewhat quirky - I don't have a 10 mbps port anywhere, however I have some flat cable that degrades connection speed to 10 mbps, maybe I will try it one day - just out of curiosity, as even 100 mbps seems to be a bit ridiculous for NAS).

I'm not very happy, having paid about 40€ for a big paperweight.

(My first WHS box - HP DataVault x312 - was mine for some 20€. And it is working fine. Another one I've got for 50€.)

HP WHS-based offerings seems to be more robust. Though I read about busted NICs on these, my two DataVaults x312 are fine (despite the same origin - trash :) ). A bit of an advantage of Acer Easystore h340 over HP DataVault x312 is motherboard form factor - one could just put any Mini-ITX motherboard in here and with some (rather serious) tinkering one could wire planar board, On switch and leds to it. For me it looks like a bit too much hassle, though.

Anyway, (again) big thanks for Nobby1805 for providing me server recovery.