Install und Einrichtung des hMailservers auf dem WHS

E-Mail auf dem WHS und weitere Themen
ThomasH2
Foren-Einsteiger
Beiträge: 10
Registriert: 9. Okt 2009, 13:08

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von ThomasH2 » 8. Feb 2010, 10:17

1: ja
2: es wird die From Adresse übermittelt und das ist Deine externe Mailadresse also Frank.Meyer@T-online.de

kontinoum
Foren-Mitglied
Beiträge: 52
Registriert: 10. Jan 2010, 16:58

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von kontinoum » 11. Mär 2010, 19:54

Bei mir erscheint bei der Installation des Programms nicht der Schritt mit dem Administratorpasswort und so kann ich mich logischerweise nicht verbinden.

Was mach ich falsch?

Billy2309
Foren-Einsteiger
Beiträge: 1
Registriert: 8. Sep 2010, 20:55

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von Billy2309 » 8. Sep 2010, 20:59

Hallo auch wenn der letzte Beitrag bisschen schon vorbei ist wollte ich mal Anfragen ob mir jemand helfen kann ?

Habe da ein Problme mit den hmailserver dieser Läuft auf einen Windows 2003 Server (root)

Nach langen versuchen habe ich es nun geschaft diese zum laufen zu bringen so das aus dern Webseite die mails verschickt werden.

Nun zu meinen Problem mit der Zeit ca. 2 Stunden ist die Warteschlange mit spam so voll das nichts mehr geht keine mails raus.

Erst wenn ich wieder den ausgang leere geht es wieder dauert aber nicht lange und ist wieder voll.

Ich habe bei spam schon alles versucht bekomme die nicht gespeert oder so das sie den Mailserver nicht voll müllen.

Weiss jemand rat für mich ??

gruss BIlly

Benutzeravatar
Grisu002
Foren-Mitglied
Beiträge: 94
Registriert: 2. Sep 2008, 09:42
Wohnort: München

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von Grisu002 » 8. Sep 2010, 22:46

CleanMail Home

http://antispam.byteplant.com/products/ ... index.html

hab ich seit zwei Jahren und Ruhe ist mit Spam
HTPC-Intel i3 4340/ASUS Z77-A/6 GB RAM/64GB SSD/Nvidia GTX550Ti HDMI/Win 10 64b/MePo 2
WHS-Intel i5 4460 Asus Z97-K/22GB RAM/10,0 TB/DVB Cine C/T, 4xDVB-C/LAV/Win 2016/MePo 2
HTPC2-Intel E6300/Fujitsu D2348-A3/4 GB RAM/32GB SSD/ATI HD4500 HDMI/Win 10 32b/MePo 2
HTPC3-Samsung Tab S/aMPdroid

MS6800
Foren-Mitglied
Beiträge: 66
Registriert: 23. Jul 2010, 14:46

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von MS6800 » 3. Jan 2011, 21:28

hallo,


möchte mir auch ein Mailserver basteln. Nun zwei frage.


* Also angenommen ich habe alles ordnungsgemäß installiert und die Mail Accounts eingerichtet. Kann ich dann diese nur in meinem Netzwerk abrufen. Sprich wenn ich mal nicht daheim bin dann geht nix ? Oder ganz Normal wie Üblich in Outlook und " Senden und Empfangen" Drücken ?

mal angenommen es geht nur im Home Netzwerk wie kann ich dann meine e-mails abrufen ? viva VPN ?


*Wenn ichs richtig verstanden habe dann kann hmailserver nur meine e-mails abrufen ? also keine Kontakte,Kalender ?



MFG
MS6800
Windows Server 2011 Standart
Eigenbau Server
3X 2 TB , 1 X 650 GB / Raid 10
2 X APC Back UPS PRO USV 1500VA

mabap
Foren-Einsteiger
Beiträge: 34
Registriert: 22. Feb 2010, 15:18

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von mabap » 5. Feb 2011, 18:37

Hallo,
ich nutze googlemail als eMail-Account und bekomme auf meinem WHS die Kommunikation zwischen WHS, hMail und Outlook Express nicht hin.
Googlemail arbeitet bei SMTP mit SSl auf Port 465 und bei IMAP mit SSL auf Port 993.
Meine hmail Konfiguration:
lokale Domain: xxx.homeserver.local (xxx ist meine Homeserver Domain für den Remotezugriff)
lokales Konto: abc@xxx.homeserver.local
Unter Einstellungen->Erweitert->TCP/IP Ports habe ich 465/SMTP/0.0.0.0 und 993/IMAP/0.0.0.0 aufgenommen

Protokoll IMAP und SMTP sind aktiviert
SMTP Konfig in hmail:
Lokaler Rechner: mail.xxxhomeserver.local
SMTP Relayer: smtp.googlemail.com, Port 465, Haken bei 'Server erfordert Authentifizierung' und 'Verwende SSL' gesetzt, Benutzer+Passwort meines gogglemail Accounts

WHS Firewall:
Dort habe ich die Ports 993 und 465 zugelassen

Konfig Outlook Express:
Benutzerinfo: Mein Name
email: Meine googlemail email-Adresse
Server: IMAP, 'IMAP und SMTP Server ist meine IP des WHS bzw. dessen Name
Posteingangsserver: abc@xxx.homeserver.local aus hmail+dessen Kennwort
Unter Register Erweitert: SMTP 465 + Haken für SSL, IMAP 993 + Haken für SSL

Wenn ich jetzt den Posteingangskorb in Outlook Express aufrufe oder eine email an ein externes Konto senden möchte kommt folgende Fehlermeldung:
onfiguration:
Konto: 'whsserver'
Server: 'whsserver'
Benutzername: abc@xxx.homeserver.local
Protokoll: IMAP
Port: 993
Secure (SSL): 1

Wo liegt da nun der Fehler? Kann jemand helfen?

Gruß mabap
Code: 800ccc0f
Server: Eigenbau WHS V1
System: 1*ST3500(500GB) - Datenplatten: 2*WD10(1TB) 1*Samsung(1TB),
2 GB Ram, Grafikkarte
AddIns: LightsOut, WHS BDBB, Remote Alert, AdvancedAdminConsole, WHS Task Viewer, Tab Reorderer, Tab Creator, Event Viewer
Router: AVM FRITZ!Box 7390
Clients: 3* Win10 64 Bit - 1*MacMini

mabap
Foren-Einsteiger
Beiträge: 34
Registriert: 22. Feb 2010, 15:18

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von mabap » 11. Feb 2011, 11:12

Hallo,

leider konnte bisher niemand helfen. Daher habe ich mich selber auf die Suche gemacht und von googlemail auf web.de umgestellt, da diese nicht über SSL gehen. Damit funktioniert nun hmailserver. Ich denke, für gogglemail muss ein Zertifikat installiert werden.
gruß mabap
Server: Eigenbau WHS V1
System: 1*ST3500(500GB) - Datenplatten: 2*WD10(1TB) 1*Samsung(1TB),
2 GB Ram, Grafikkarte
AddIns: LightsOut, WHS BDBB, Remote Alert, AdvancedAdminConsole, WHS Task Viewer, Tab Reorderer, Tab Creator, Event Viewer
Router: AVM FRITZ!Box 7390
Clients: 3* Win10 64 Bit - 1*MacMini

go4java
Foren-Mitglied
Beiträge: 234
Registriert: 19. Mai 2009, 13:57

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von go4java » 11. Feb 2011, 11:19

Hallo mabap,
hatte damals auch evaluiert, ob sich ein eigener Mailserver auf dem WHS "lohnt", habe mich aber aufgrund eines unvermeidlichen Admin-Aufwands dagegen entschieden.
Für mich ist Google Mail die E-Mail-Zentrale und weltweit leicht erreichbar, die alten Mailkonten sind dorthin umgeleitet. Außerdem hat man eine exzellente Suche über historische Emails und die logische (und visuelle) Verknüpfung von zusammengehörenden Konversationen.
Vielleicht hilft Dir aber auch folgender Blog weiter: http://www.jeffkastner.com/2010/01/blat ... and-gmail/
Gruß
- 3 Notebooks mit Windows 10, 8GB RAM, 256GB SSD
- HP MicroServer N40L (Raid 5) mit 4 internen Platten Western 1TB und 1 (externe) USB2.0-Backup-Platte Western 2TB
- Telekom Speedport Hybrid mit DSL/LTE

mabap
Foren-Einsteiger
Beiträge: 34
Registriert: 22. Feb 2010, 15:18

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von mabap » 21. Feb 2011, 10:52

Hallo,

vielen Dank für die Antwort. Ich habe inzwischen den hMailserver wieder vom WHS deinstalliert, da der Versand auch über die üblichen eMail-Wege funktioniert. Ich sehe keinen Vorteil in der Installation eines eigenen eMail-Servers!
Gruß mabap
Server: Eigenbau WHS V1
System: 1*ST3500(500GB) - Datenplatten: 2*WD10(1TB) 1*Samsung(1TB),
2 GB Ram, Grafikkarte
AddIns: LightsOut, WHS BDBB, Remote Alert, AdvancedAdminConsole, WHS Task Viewer, Tab Reorderer, Tab Creator, Event Viewer
Router: AVM FRITZ!Box 7390
Clients: 3* Win10 64 Bit - 1*MacMini

JulianD
Foren-Einsteiger
Beiträge: 15
Registriert: 13. Aug 2009, 12:56
Wohnort: Bochum

Re: Install und Einrichtung des hMailservers auf dem WHS Tei

Beitrag von JulianD » 22. Jul 2012, 21:13

egbert hat geschrieben: Anmerkung: Für T-Online-Kunden muß hier der leider kostenpflichtige SMTP-Relay eingetragen werden.
Hierzu habe ich eine Frage.
Mein Aufbau:
Ich habe eine Domain registriert und dort in den Namensservereinstellungen alles nötige auf meine homeserver.com Adresse umgebogen.
Die Mail-Adressen habe ich im hmailserver eingerichtet, die Anbindung per IMAP klappt. Ich kann Mails an meine dort eingerichteten Adressen senden, diese kommen auch an.
Mein Provider ist die Telekom.
Als SMTP Relay habe ich den Server meines Domain-Hosters angegeben (domain*go).
Der Versand der Mails klappt nicht. Liegt das nun daran, dass ich bei der Telekom bin und nicht das Mail-Paket habe oder ehr an einer "Fehlkonfiguration"?
Denn eigentlich hat die Telekom mit dem Ganzen nicht zu tun oder?
Den Port 25 nutzt ja beispielsweise auch Thunderbird.

Hier mal das Ergebnis der Diagnose des hmailservers:

Code: Alles auswählen

Test: Collect server details
hMailServer version: hMailServer 5.3.3-B1879
Database type: MSSQL

Test: Test IPv6
IPv6 support is available in operating system.

Test: Test outbound port
SMTP relayer is in use.
Trying to connect to host smtprelaypool.ispgateway.de...
Trying to connect to TCP/IP address 80.67.29.4 on port 25.
ERROR: It was not possible to connect.

Test: Test MX records
Trying to resolve MX records for damhus-net.de...
Host name found: damhus.homeserver.com

Test: Test local connect
Connecting to TCP/IP address in MX records for local domain domain damhus-net.de...
Trying to connect to host damhus.homeserver.com...
Trying to connect to TCP/IP address 87.147.29.95 on port 25.
ERROR: It was not possible to connect.
ERROR: Was not able to open connection.


der-harribert
Foren-Einsteiger
Beiträge: 14
Registriert: 7. Nov 2013, 15:42

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von der-harribert » 30. Apr 2015, 15:47

Hallo zusammen,

ich habe den hmailserver auf meinem WHS installiert und eingerichtet. Gemacht habe ich das ganze nach der Anleitung von Heise:
http://www.heise.de/netze/artikel/E-Mai ... 84479.html

Vieles hat ganz gut geklappt, ich komme jetzt aber mit den internen / externen Domains gewaltig ins schwimmen. Ich habe eine Domain bei strato. im Homeserver habe ich denn die Domain blabla.local eingerichtet.
Den externen Account habe ich dann mit den Starto daten eingerichtet.

Als Mailprogramm nutze ich Thunderbird. Dort habe ich dann die IMAP Verbindung zu projekt@blabla.local eingerichtet. EMails kamen bei mir an und ich konnte auch welche verschicken. Die kamen in einem anderen Mailaccount auch an, nur stand als Asenderadresse dann projekt@blabla.local

Dann habe ich die E-Mailadresse in Thunderbird geändert auf projekt@strato-domain.de. Die SMTP und IMAP Zugangsdaten aber auf den Daten von projekt@blabla.local gelassen.
Dann wollte der hmailserver die Mails aber nicht mehr nehmen und verschicken.

Hat jemand ne Idee, was ich falsch machen?

Schöne Grüsse von mir.

nobbynews
Foren-Einsteiger
Beiträge: 30
Registriert: 5. Jul 2009, 10:20

Re: Install und Einrichtung des hMailservers auf dem WHS

Beitrag von nobbynews » 3. Mai 2015, 08:18

Hallo,

die IMAP-Einstellungen bei Thunderbird beziehen sich immer auf das lokale Konto, als project@blabla.local.
Die anderen EXTERNEN Email-Adressen habe ich bei mir in Thunderbird innerhalb des Kontos unter "andere Identitäten" definiert.
Allerdings könnte es dann Probleme beim Versandt mit den Provider geben, da in der Regel Emails die nicht auf z.b. provider.de enden vom SMTP-Server abgewiesen werden.
hmailserver kann zwar viele externe Konten abrufen, aber nur bei einem SMTP-Server selbst abliefern.
Hierfür hilft einem dann ein Relay-Server weiter.

Gruß
Norbert

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast